Download

Disable DOF for certain objects?

I use distance-based DOF just to soften the image for far away objects, However I’d like to disable it only for my skybox.

Does anyone know if this is possible in UDK?

I think UDK ignores DOF on translucent objects. If you want to disable DOF on your skybox, you could try making it translucent, but then set its opacity to 1. That could cause other issues though, like maybe with smoke or other translucent particles that would draw in front of the sky.

Besides the translucency hack, I know of no other way to disable DOF on just one actor. Maybe you could do something crazy to draw the skybox in post processing.

depth sorting would be easily fixable by setting the skybox’s Translucency Sort Priority to -1 :slight_smile:

Thanks for the tips guys. I’ll give that a shot.

isnt it something in the material or texture settings?
sure i remember something like a “skybox” setting…

I don’t see any setting for skybox anywhere in the material editor or texture settings unfortunately.