Disable depth test not working on IOS?

Just like the link below:Is Disable Depth Test not supported on Mobile? - Mobile - Unreal Engine Forums
I have come across the same issue,I have a projectile particle which is set to additive,when it flies across the waterplane(which is set to translucent),it will become invisible as if the translucent is drawn on top of the additive,I want to disable that,so I check and uncheck the disable depth test in my water material but does nothing in mobile preview and the editor,however,if I uncheck the separate translucency in the water material,it works in editor but still not worked in mobile preview and the mobile devices(iphone 6 plus).I think it is a bug
I have test another one:I create a translucent particle,and dynamicly spawn it behind my opaque character,but it sitll can be seen through my character…I want to disable that…(Now I found that this works on android but not IOS)Thanks!

Hi,

It looks like sorting issue. Translucent objects get sorted from back to front using mesh bounding box origin position. So probably at some view angles your water plane gets rendered after projectile. You could try to set lower sorting priority for water plane mesh and see if it helps. In actor details Rendering->Advanced->“Translucency Sort Priority” set it to -1 for example. Make sure that “Disable Depth Test” is off on translucent materials.

Thank you very much!That really works!

I have found that only translucent material works well with the Translucency Sort Priority,the additive material still can be seen through opaque actor in some angles on IOS devices…Maybe that a BUG.Thanks very much!

Any new information?Thanks!

Does this additive material has “Disable Depth Test” switched on? If it’s switched off and still can be seen through opaque objects, then it’s a bug. Could you send us minimal project where it can be reproduced?

I‘m sure it’s switched off.After further digging,I found that this issue only happens on metal not es2.Here’s the screenshots,the first one is taken from the mobile preview and the second one is taken from actual ios device(iphone6 plus),we can clearly see that the ripple are drawn above the mesh on ios device(metal)while in mobile preview not.

59180-mobile+preview.png

59191-iphone6plus.png

Sorry for that I cannot reproduce it myself,when I create a clean topdown project and add these to it and enable metal and then package to the iphone6 plus,the issue is gone,I really don’t know why…

Could you move opaque mesh a bit up, so there is more distance between ripple and opaque mesh and try it on device?

Thanks!But even if I move the opaque mesh far away up to 50 units,this issue still happens on metal enabled devices…

I’m sure this never happens in es2 but on metal…