Download

Disable "default" maps in material instance

Hi all,

I’m fairly new to UE, but am starting to get to grips with material/shader creation using Master/Instances.

I’ve created a master material that I’m pretty happy with, and I’ve noticed that when setting up some instances there are situations where I don’t require some of the maps (let’s say specular map for example), and even though this remains unchecked it still shows the map that was present in the master material. I’ve tried to “clear” the map slot, but to no avail.

How do I stop this from happening?

Many thanks,
Chris

You can use a static parameter switch to determine if the whole section is to be utilized or not.

Beware, master materials can cause performance loss.

Thanks!

How dothey cause performance loss? I’d have thought (wrongly?) that having to compile a handful of materials would be better than compiling hundreds, no?

Anybody know?