Download

Disable Debug on Apostrophe pressed

Hello, I need to use Apostrophe in my game, but it turn on some debug mode or something, and doesn’t do what it is supposed to do. How can this debug be unbinded from apostrophe? Thanks

Put this at the top of DefaultInput.ini and it disables a bunch of stuff. It doesn’t work on apostrophe anymore though. Anyone got ideas on that one?



[/Script/Engine.PlayerInput]
-DebugExecBindings=(Key=Escape,Command="CloseEditorViewport")
-DebugExecBindings=(Key=Q, Command="CloseEditorViewport", Control=True)
-DebugExecBindings=(Key=F1,Command="viewmode wireframe", bIgnoreShift=True)
-DebugExecBindings=(Key=F1,Command="ShowMouseCursor",Shift=True)
-DebugExecBindings=(Key=F2,Command="viewmode unlit")
-DebugExecBindings=(Key=F3,Command="viewmode lit")
-DebugExecBindings=(Key=F4,Command="viewmode lit_detaillighting")
-DebugExecBindings=(Key=F4,Command="viewmode detaillighting")
-DebugExecBindings=(Key=F5,Command="viewmode shadercomplexity")
-DebugExecBindings=(Key=F9,Command="shot showui")
-DebugExecBindings=(Key=F11,Command="LevelEditor.ToggleImmersive")
-DebugExecBindings=(Key=F11,Command="MainFrame.ToggleFullscreen",Shift=True)
-DebugExecBindings=(Key=Pause,Command="Pause")
-DebugExecBindings=(Key=Period,Command="RECOMPILESHADERS CHANGED",Control=True,Shift=True)
-DebugExecBindings=(Key=Comma,Command="PROFILEGPU",Control=True,Shift=True)
-DebugExecBindings=(Key=Tab,Command="FocusNextPIEWindow",Control=True)
-DebugExecBindings=(Key=Tab,Command="FocusLastPIEWindow",Control=True,Shift=True)


For the record since this is the first google hit, there are two ways to disable the Apostrophe key:

(1) ProjectSettings >> Engine >> GameplayDebugger >> ActivationKey >> None

(2) Manually edit DefaultEngine.ini with the following:

[/Script/GameplayDebugger.GameplayDebuggerConfig]
ActivationKey=None

BTW, devs not disabling this in shipped games ends up as user annoyance:

https://dungeondefenders.com/2/topic…=135346&page=1

https://steamcommunity.com/app/35450…3165427559527/

Hi ! Don’t know if things have changed.

On latest version 4.26.1, it seems that even doing that does not work.

I tried putting this :
[/Script/GameplayDebugger.GameplayDebuggerConfig]
ActivationKey=F6

The debugger does display if I press F6. But it still displays too if I press “Apostrophe” even if I have another binding on this key… So frustrating.

Solution is here, enjoy!

1 Like