Disable Character Moving during Animation (Root Bone is not moving already)

I downloaded some Mixamo animations and retargeted it to my default UE4 character. However, when I use the animations, the character moves around (ie doesn’t stay in the 0,0,0 position). I thought that maybe the root bone was moving along with the animation but when I clicked on the root bone to see its location during the animation, it was on the 0,0,0 mark throughout. Was this due to a retargeting issue as the Mixamo Skeleton did not have a root bone? And is it possible for me to stop the animation from moving about? I tried unticking the Enable Root Motion box but it still did not work. Thanks in advance!