Disable character interaction on physics object within a blueprint

So it seems like disabling physics interaction in the character movement only works with normal physics objects. Is there any way to actually disable it on physics objects within another blueprint?

The box I am moving here isn’t even supposed to be allowed to block the character. They should just both overlap each other…