Disable automatic animation compression?

There seems to be some sort of automatically-applied (i.e. before ever pressing “compress animations”) compression scheme on animations I import into UE4.

What I’ve done is created a single animation for two actors, and then I play both simultaneously (triggering them via the same execution path), using .fbx anims exported individually (i.e. from the single Blender scene I export an FBX for each of the skeletons, and then play both montages on the corresponding actors concurrently).

They sync up for the most part, but there’s clearly parts of the animation where the animations seem to be skipping relevant keys.

Take a look at the screenshot below:

You can see the desynchronization happen most prominently here; the enemy tracks the player’s hand frame for frame in the animation in Blender, but this is all removed in the actual in-game animation sequences.

The thing is, I haven’t actually applied any compression to these anims… so why is it happening this way? There doesn’t seem to be any general desynchronization in the TRIGGERING of these anims (they seem to play properly in sync most of the way through) but in certain spots it seems like individual keys are just being dropped and the interpolation is being (poorly) handled automatically.

What do?

I’m sorry, this is my own fault! It’s not actually the animation being compressed, it’s a result of time dilation mismatch (the player has a dynamic time dilation which wasn’t being properly copied to the enemy actor in all cases), which was small enough to make the attack look MOSTLY right until the very end where the slippage started to become noticeable. It’s just a coincidence that it appears in a spot where a filter/lerping of anim keys would produce a very similar desynchronization (since the grunt has to be retouched every frame in small ways to keep the anims synced) and misled me.

Do you have any experience in how time dilations can mess up animations? I set my global time dilation to 0.1 and then sped up my animation 10x to compensate so that it looks normal, but what actually happens is half of the animation is actually skipped.

Somtimes… animation compression in Unreal is a nightmare. Can it be disabled?