Download

Disable ALL VR Plugins by Default

Now, I am a VR dev, and for the most part, it works just fine for me sometimes. However, I don’t always work on VR games. And it’s just a little annoying having SteamVR or OculusApp pop up everytime I open up a project.

The solution is easy, just disable the plugins every time we start a new project. But, let’s be real. most of the devs aren’t doing VR projects to start with. So why are they even enabled by default? We need a cleaner Editor for new projects. There’s a ton of stuff (c + rap filtered out really?) that have no business being on by default, especially in the Plugins section.

#ReduceTheBloat

Thanks.

+1. Disable all VR plugins by default. I do not develop for VR nor have intention to do so. Yet for example when building linux dedicated server VR plugins add dependencies to build. For what reason, I can’t fathom.

This is still an issue in 4.20. It seems crazy that Oculus VR and Steam VR are enabled by default. Surely they should be set to disabled as the default engine setting, and enabled on a per-project basis if that project uses VR. And this is coming from someone who develops in VR a lot.

I agree, everytime I start a new project I first have to disable all these unnecessary plugins, like all those for mobile dev or things like the Speedtree importer. I’m not using any of these, why is it enabled?

It would be much better if, while creating a new project, I get a list where I choose which plugins I WANT to enable - and only the necessary plugins that everyone needs are enabled by default.

Yup, having to go in and disable, restart the editor every single time is extremely annoying especially if you forget to do it and need to shut down all the VR apps and wait for the screen to come back. At least give us the ability to set defaults.

Hey folks - this is on our radar to fix for ya :slight_smile:

Thank you Amanda! I hope you can make it for the next version, 4.21? That would be awesome!

Any news? It became even more painful lately, because now Steam VR cries for updates and started to crash randomly. Dude, just get lost.

:slight_smile: Sadly my sweet feature requests never make the cut ;(

+1 Please put this in, @Amanda.Bott do you have an update?

Please disable VR by default, it’s so irritating having to manually disable it everytime there’s an update.

Please disable this by default.

What? Why? Information about disabled modules is saved to .uproject file. You need to do it once.

Once for every project and engine version. It’s a constant pain point. It really should be disabled by default.

Please see https://github.com/EpicGames/UnrealEngine/pull/6003 which hopefully addresses most peoples issues with this. Basically I added a button in the New Project Wizard that allows developers to disable all VR plugins when creating a new projects. Cheers,

It took two years, but… it happened.

are you sure?
in 4.24 VR is still on for me by default. and as a educator i open shitload of new projects all the time. it’s such a pain to always disable it for every new project.

it’s been two years…

Yep, still launching VR for every project I start. 4.24.3 Ugh, this is just really annoying.

This is *still *a problem. Why? How can we draw more attention to this? they’ve acknowledged this was an issue 2 years ago and done nothing. It’s such a ridiculous assumption that everybody, ever, is definitely working on a VR project.