Download

Dinos following in caves?

Does anyone know where is the line located that prevents tamed creatures to follow you in caves? I’m having some problem with bringing tamed Titanoboas out of the cave as they don’t follow you, not even after you bring them to surface by riding.

The pathing is controlled by the dino AI blackboard system however the problem you are experiencing with dinos entering caves is more the bounding box that some dinos have. For example a sabertooth’s collision box is huge compared to its actual model.

I’ve already dealt with the collision. The only problem I have that the creatures within the cave have their Follow AI pattern disabled. Even riding the Titanoboa out of the cave will not solve it, it will still not follow you. Nor will trying to reset its movement with Obelisk/Argentavis. Creatures spawned on land will function to the fullest. They have working follow etc.

Yea, I am getting a similar problem. It could all be for nothing though, since the new patch is “auto-killing” animals that are not supposed to be tameable. I don’t know if your animal would fall under that criteria, but it very well could.

It’s not auto-killing my Boas since I’m using my mod where they are tameable. Also it says that it’s server side fix so I’m not sure if it affects private servers.

Good to know, I wasn’t sure how the code was laid out, but that’s good to know that it’s not searching out all variants of boa’s, spiders, bats, etc

So you are telling me not even dillos follow you into caves anymore? They absolutely used to.

No, I mean creatures that spawn in the cave and once tamed don’t have a follow function at all. Let’s say I go into a cave and tame a Titanoboa in there. The Titanoboa will stand still no matter how you try to get it to follow you. The only way to move it is to ride it yourself. After riding it back to surface and trying to pick the Boa with Argentavis and uploading/downloading it into the Obelisk it still won’t follow you. “Attack that target”, “Neutral” and “Passive” orders work just fine. The follow is the only thing that is missing from the AI.

Now if I summon a Titanoboa with console when I’m inside a cave or outside a cave and then tame it. It will have a proper and fully functional follow.

You can still easily take some mounts into the caves. That’s not what I’m saying. I’m talking about creatures that spawn naturally in the cave.

If in one scenario (summoning it) it will follow but wild it wont follow you then that sounds like it is just a bug. The bug may exist in blackboard, but the fact that summoning it and taming it allows it to follow means that the code is there. It is likely because cave creatures are not naturally tameable so they never checked for bugs with those creatures in that respect. You could attempt to bug fix it yourself or see what happens when you throw on a different AI. If I were to take a stab at why, its because naturally spawning cave critters (with the exception of one boss spawning spiders - entirely different spiders though) are exclusive to that cave zone. To the AI, that cave might be all it can see, or it could be the opposite - when AI is tamed it knows it is underneath the persistent world and has no pathing to work with.

I’ll try to look around the files to see if there is something I can do about it. I’ll just have to live with it for now.

Any devs that could give me hint :3?

If you can put in a graph event to be triggered or watch for a follow command, I think you’ll find that because they are spawned in the cave their follow scripting will be entirely disabled, I doubt very much they would delete the component/scripting but as they are deliberately set untameable even scorpions that are available topside they would of disabled the follow script to save the 30-200 creatures in the 6+ caves around the world constantly polling for a follow event.

So my guess is 1 of 2 things are happening, they are ignoring the “follow_me” event trigger, or the follow script is entirely disabled to save redundant server execution.