Dificulties with my project

I’m having difficulties with my project. I can’t get my character to play: I put him there, but when I play, I control another character and not mine. How do I see what I control in the editing world?

Thanks man but it didn’t work. What I mean is for example: when you open one of the templates you see the scene, the character, the player start. But here in mine I see the player start, but I don’t see where my character is and if I add it, it’s like an npc and not as it was in the template, you know?

on the detail panel of you pawn instance (in your level ) there is an option called autoposses player.
choose player 0 and it should work.
otherwise, you should create a custom game mode , put your pawn in its settings and assign it to your level

so try this :

  1. be sure that your character inherits from pawn class

    2 ) in your level

    put a player start.

    create a new game mode using this tutorial : [https://docs.unrealengine.com/en-US/Gameplay/HowTo/SettingUpAGameMode/Blueprints/index.html][1]

    except that in the default pawn class, you choose your character blueprint

now go to the world settings panel of your level, and set the game mode you just created as default game mode (note that sometimes you have to restart the editor for changes to work)

now before playing, push the small arrow to open the details , and choose “default player start” :


Noneit didn’t work, let me show you what i want. See the print below

I don’t see my character. But if I put it like the image below:

the game looks like this:

I know, but the same problem remains:

sorry to insist but you have to specify a game mode here :

overwise it won t work as you expect

I want it to look like this in this video at 5:29

you mean having having a second render of your pawn like this ? :

No, this I can do, what I can’t do is another function that needs my character to appear in the editing mode.

you mean seeing it in the editor and being able to possess it in play mode?

Yeah yeah!

then :

  1. delete the player start
  2. make sure you have only 1 copy of your character in your level
  3. select your character in the viewport and in the detail panel put these settings :



Thank u man! It worked

so flag the answer for further people searching !