Download

different problems

Hi, I’m trying to to reach some good result with Unrealengine on archivitz

here attached the result of my testing
riferimento.jpg

The result it’s quite far from being photoreal (still many UV to set properly) but before going in deep with the set-up of the scene (materials, postprocess…and other) I must solve some main problem found:
problemi.jpg
1: the ceiling shadows, I tryed to encrease the lighmap resolution but the shadows is getting sharper and jagged (lowering the lightmap resolution gives “better” result…but simply because the shadows are “spreaded” away)
2: no contact shadows for the chairs…and no shadow at all casted from their legs
3: orrible effects from the mirror…how to avoid?

Another little thing: this shot (due to the small dimensions of the room) was made by changing the “clip plane” in the “general settings” of the scene…is there some other way to reach such result?, maybe the possibility to enable this effect directly to some certain camera?

Hope that someone could be helpful :smiley:

If the geometry is a static mesh you must raise the lightmap resolution, 64, 128,256,512,1024,2048 and so on. If it’s a brush you must lower it. Try a value of 2. (default is 32 I think). Are your settings set to Epic in the editor?

You can also adjust the lightmass settings : Here I’m playing with Koola’s demo on the marketplace and I’m trying to push realism even further. I bumped the lightmass quality settings. the lightmaps varies between 256 and 2048. Using production lighting settings too.

Untitled.jpg

For the reflections, you can check if it’s set up correctly on your post process volume :

58bc717ea059a06ae6ce51031218194b35fc8662.jpeg

Thanks for your reply heartlessphil, I still have tried increase the lightmap resolution but it gives me a worst result…I’ll make some test adjusting the other parameters you pointed out.

I’ll let you knowhow it goes

I’m getting quite nice results without using plane lighting techniques. Try to use just directional light and a bit of skylight. Then play with indirect light fill in postprocess to achieve desired lighting
Mirror thing-did you use reflection gizmo? Play with that.
Don’t forget about ambient occlusion (post process or world settings), it could help with chairs shadow.

thanks for the hints pkarpiozo, I don’t use planes for lighting too (seems they don’t produce shadows), I’m using two spot light (90° inner and outer cone angle), no skylight (maybe I can try to use it), still just using post process for boost up the light and a bit of contrast…keep testing with tons of settings :confused:

Have you manually unwrapped your UVs or they’re automatically generated by UE4? I think the automatically-generated UV lightmap (channel 1) are made based on your texture UVs (channel 0). If your texture UV is a mess, don’t expect much form the auto UV lightmap. I might be wrong but I recall reading that somewhere on this forum!

Still, the best way is to make a second UV channel in 3ds max (or any 3d software) and unwrap your UVs yourself. At the very least, a flatten mapping.

If you want, send us your file and we’ll see if we can tweak some stuff!

Thanks for your advice heartlessphil
no,all the UV are made by me (except for the “library” objects for which I made only the 2nd UV channel by a flatten UWV Unwrap with a value of 2 of padding).
Here is the last update (seems good emprovement), those are the adjustments adopted:

  • as you suggested, for the reflections I have bosted up the settings into the postprocess volume…good results but there is still a strange behaviour in the reflection (only when I am lot near the surface)
  • I changed the two outer front lights from “static” to “stationary” and enabled the “Used RayTraced distance field shadows”, it changes completely the mood (better shadows and light propagation)
  • change the orientation of the directional light and set to “0” the “indirect light intensity” for avoiding the strong color bleeding due to the high saturated color of the bed.

aa409dd536774071e5f71ec52d85fe4cbffb902e.jpeg

still the trouble of lack of contact shadows fot the chairs and the bed legs…don’t know how to solve it :confused:
…strange behaviour occurred when I switched from static to stationary, before, no highlights were visible, now they are visible (…two white splotches on the mirror and on the bed wall. They don’t look too good on the mirror and I know that with the “min roughness” parameter they can be spreaded away…but I don’t want to erase them from the bed wall too).

If there is the need I can send you the scene heartlessphil, now the only issue is the contact shadow, after that just tweaking materials and settings for trying to make it realistic :rolleyes:

Hi PaoloVerona,

for the contact shadow, does the floor happen to be a dynamic mesh?

Hi hardyhutajaya, all objects are static I have tried to move the objects coloser (little inside) the floor but nothing changed :frowning: …really don’t know how to do