Download

Difference in the quality of my textures betweens what I see and UE4

Hi everyone,

It’s my first post and I know that some people who tell me that there are differents post on that subject but nothing works for me.

Here the problem, I create texture with Photoshop and Susbtance Designer with a resolution equal to what I want or 2x (*) but when I import them and create a material, the quality is not good.
But i don’t know where this problem is coming for ! I will tell you what I’ve done with a test scene.

*if I want a 512px, sometimes I’ll do it in 512px or in 1024px, too get more detail and I reduce the size later

  1. Open a empty scene and add Directionnal Light and a sky light with a HDRi
  2. Change some paramaters to the light and World (Dynamic Shadow for the light, and the first & second parameter for the world to increas the quality)
  3. Import a mesh with 2 UV, all smooth (I use the normal map to get hard edges)
  4. Import the texture:
    • Disable sRGB for all maps to get true color
    • Able “Never Stream”
    • Change Group to Sharpen and define Tri-linear for the anti-alliasing
    • Invert the green channel for the normal map
    • Roughness and mettalic map in grayscale
  5. Create the material and add it on the mesh
  6. Build in “Production” quality

92cb3d79424ae992b7488958ff56d768f064e610.jpeg

Can someone help me or has a idea about this problem

It’s just blurry because the resolution is low and the engine stretches the texture. You should try to make them atleast 2048x2048 for the best quality.

I could do that but that problem appears on almost all my textures and if I have to change the resolution to 2K, the render time will be enormous.

But what do you mean, the engine stretches the textures ? Is there a reason to it ? Can I disable it or it’s just a thing of UE4 ?

This is completely normal. Just zoom on your texture in Photoshop until you display it at the same size as your UE screenshot. How does it look then ?
The red part of the texture is maybe 100px across and you stretch it onto 5 times that on the sreen, it can’t possibly look good.

Also, you are wasting 90% of the UV space. You want the part of the mesh that has a detailed texture to occupy most of the space, the gray part doesn’t need this much.

When you unwrap things, the things you want to have textures on, like the little character, needs to be the biggest piece. Alternatively, you could assign each part of your model to a Red, Green, or Blue color. Then in UE4, assign a material to each color. That way you have a lot of control.

In your situation, you could make those graphics be a larger size in the texture so that you can have more detail in the texture map–the artifacts are due to the texture compression when you import to UE4. You can try adjusting the compression in UE4 or try to adjust your texture to have more detail. I’m thinking you don’t need all of that empty gray space there. If it’s an issue with UV mapping, then it would be better to add a loop or something in your mesh so that you can set up the UV’s and place your graphic in exactly the right place without having to have a large empty space in the texture map.
Try to avoid using huge texture maps since that will increase the memory.

Thanks for the answer guys, I will make some adjustements with the UV and the texture size and see what it looks like !

I posted a new mage today to show you the difference ^^

I change the way I think about this object. It’s just a plastic garbage can with somes instructions and a image, so I decided to use decals.
This way, I can shrink down my textures and still have a good result, but also remove all the noise from the image of the soda.

Here what it looks like !

There’s just the problem with the constrast of the decal but I think I use .tga, there’s always some sort of desaturation with png