Did sprite "extract sprites" break in 4.9?

Hello All,

First off let me say unreal Engine is by far the best game maker out there, props to Epic and the community for making such an amazing free tool.

So I think Extract Sprites is broken. I tried transparent backgrounds, I tried really thick black outlines in hopes of “helping” the extract process but still nothing. Something broke in 4.9 I’m sure of it. It simply will not extract sprites intellectually. In previous versions I could extract sprites in what appeared to be in “Shrink Wrapped” fashion. Now all I have is grid (which doesn’t work too well for my designs) and “Auto” which can barely recognize the separate assets in my sprite sheets. It is very discouraging. I’ve attached an example (this occurs generally for all my sprite maps, in paper 2d AND 3d).

As you can see in this pic, AUTO is selected but you will notice NO YELLOW BOUNDS are drawn.

I go ahead and extract and get only 1 sprite


My source texture has the proper transparencies (it is a png).

Please help,

Thanks !!!

Hello fungusman,

Interesting I tried to extract sprites and I see the yellow squares.

In order to better understand this issue I would like some information from you.

1.) Does this happen in a clean blank project?
2.) Can you link me your DxDiag?
3.) Can you link me the texture you are having this issue with?
4.) Does this happen in the 4.10 preview 1?

After I have this information I will be able to narrow down what is causing this.

Sorry for the slow reply .

2.Please be specific about what info you need from it (too much data to post publicly)
4.Happens in 4.10 stable. screenshot attached.

Info as in, your operating system, graphics card, the last time your graphics card was updated, how much Ram you have. Essentially your system specs that could possibly influence anything graphical inside of UE4.

Thanks for the reply . I dont think this is the case lol but here is your info.

  • Windows 7 64 operating system,
  • NVIDIA 760 graphics card, TODAY was
  • the last time your graphics card was
  • updated, 4 gigs of ram

As I am unable to reproduce this issue I cannot report this as a bug. However, I do believe this issue could be related to the amount of RAM you have currently installed on your machine.

This is from our documentation regarding minimum recommend specs for developing with our software.