Did docs.unrealengine.com just get wrecked?

I was using it moments ago to look up some C++ API and it suddenly stopped working. Seems like docs.unrealengine.com is under a new format now, with C++ API nowhere to be seen.

Any information regarding this change?

They moved doxygen pages of API to new adress:

can’t access any class docs or anything. i’ve tried setting the url relative path directly from the above, and doesnt work!

Yeah, the search is screwy. If you navigate manually through the API link you can find most stuff, but it’s cumbersome… search leads you to the old URL scheme which doesn’t work.

RIP tags…
BP search does not work as well.

[FONT=courier new]Much like Bruno indicated, you can access the documentation by replacing the sub-domain from ‘docs’ to ‘api’. Search for what you need, then replace the sub-domain. Quick example using a search for AActor:
Invalid URL: AActor | Unreal Engine Documentation
Valid URL : AActor | Unreal Engine Documentation

I would have to assume that there are some cases where this simple substitution does not work, but the majority of cases I had tried were a direct translation.

Oh, thank you! I was a bit confused (not a bit actually).

Hey guys,

Sorry for the confusion here. We should have had redirects in place to make sure existing links worked and took you to the new location for the API references. I think we have those working now, but I apologize for the hassle it may have caused.

Let me know if you are still seeing any links not working. Also,let me know if you have any other questions or concerns about any changes you may be seeing.

I’m getting some 404’s when trying to access the blueprint node reference pages. [USER=“7”] Wilson[/USER] what’s going on there?


From this page Programming with C++ | Unreal Engine Documentation all theUnreal Engine API Reference links are broken


I can’t access most pages.

I search here: http://api.unrealengine.com/INT/API/index.html
Click on the result and get URL: http://api.unrealengine.com/INT/Blue…ion/index.html

Content: 404 Not Found

  • Code: NoSuchKey
  • Message: The specified key does not exist.
  • Key: INT/BluePrintAPI/Game/GetWorldOriginLocation/index.html
  • RequestId: 7037A6EADB780052
  • HostId: E0/cCBb/a6c/zK6nHL9Z+NbZojcY+F00YEztWX4v9G/3U9BwtBhZbJIdxAW7s+IOAH75obo7XWE=


I’m not sure where that capital P in Blueprint in the URL is coming from. It should be “BlueprintAPI” and then the URLs seem to work fine. We will have to look into that.

We will get those links on the Programming Guide fixed up as well. Sorry about that.

Anyone knows where I can access the docs for UE3?
This used to also work last week.

Then I tried the suggestion here to replace *docs *with api, but I’m also getting an error.

 404 Not Found

  - Code: NoSuchKey
  - Message: The specified key does not exist.
  - Key: udk/Three/WebHome.html
  - RequestId: 61648A77625DF299
  - HostId: tZCIhkVdiIV3m+LVvUHTQhMCoqQw8eSvWFUC6fbilxWzc9PLIloiaVpAyoeyY1Rx5anAmoLHWtc=


The UDK documentation is not currently available, but we are working to get it uploaded to a new location ASAP. I will be sure to let you know as soon as they are available again. The old links should redirect to the new location once they are uploaded.

Again, I apologize. We are trying to do things in steps to avoid too many moving parts, but I do realize that is not ideal for everyone.

Thanks for the response , glad to know that it will still be available soon. Cheers!

When I search here: Unreal Engine 5.3 Documentation | Unreal Engine 5.3 Documentation
You lack the choice of filtering between All, Unreal Engine, Documentation, C++ API, Blueprint API, Forums, Answers, Wiki, and Video Tutorials.

I hope you are not planning on getting rid of this feature altogether? Currently, the only way to get the old search seems to be by using the search on the main page: https://www.unrealengine.com

I also feel like the new search gives worse results and rarely what I’m looking for. Example:


The first link gives me precisely what I want, which is “Unreal Build System Target Files,” that’s nowhere to be seen on the second link unless I further narrow it down.

Also, can you look into making the documentation available for download and offline use?

Yeah, but the global search sits right above. Maybe we need here a clear distinction between these two ways to search, i.e. by adding ghostly text “Search documentation” in Docs Search.

[USER=“184151”]Erik Bye[/USER] as [USER=“69”]Just Krishna[/USER] said:

Noted. My concern is that it will be removed. Just wanted to make sure they know that search method is really useful.

We do not plan to remove the global search. It will remain available in the site header.