Download

@devs- Question about sound modding

I changed the sound for the T-Rex roar and tried to sync it with the Animation. Do I have the possibilty to upload/play it as a mod on the island and not just on the test map nad if yes, how can I do that? The tutorial doesn’T really help me there. :frowning:

Should give you all the information you need regarding that.

That’s my problem, it doesn’t really help me because the sounds I modified are connected and synced to an animation and I don’t know how to add sounds or animations to the blueprints. (or whatever you have to do)

I’d really like to have an answer. :smiley: It bothers me that I can’t mod right now because I’m to dump to do so.

Be sure to look over the two asset files in the GenericMod, those two files are loaded up with the mod’s blank map file (in the case of a generic mod to only replace assets) before loading up another map. For your mod you can just create a child blueprint from the parent of those assets by finding the parent in the content browser and then right clicking and selecting “Create blueprint based on this” (to undo the changes they made to make the primal game mode mod, which is what the GenericMod is). It will create a child blueprint that you need to move to your own mod folder. Inside your new PrimalGameData_BP_Child blueprint you will find DinoEntries. Here you can change the base game to use a new dino blueprint (that would be utilizing your new sounds/animations). From here you basically repeat the process of creating a child of that dino and going deeper and changing what you want to change along the way until you accomplish your goal.

This helped me alot, thank you, but now I’m stuck at editing the DinoEntry_Rex. Any ideas how I could add a new sound to that?

DinoEntry_Rex is for the icon when taming/looking at a tamed dino. You should be looking at Rex_Character_BP and more specifically at the sound cues referenced by this blueprint. I also recommend exploring the assets by right clicking an asset and clicking “Reference viewer…”.

I really appreciate your help and I hope I’m not annoying you, but if I could ask one more questions that would be great.

What I don’t understand is why the game doesn’t recognize the sounds except when I am in the test map. The reference viewer tells me that all of the animations and sounds (the ones I already changed too) are connected to the Rex_Character_BP, but they just don’t show up.

Another weird thing is this: 021311386efbe9af15dd144375f1f621c4eb5e21.jpeg
It says that only the DinoArena map is referenced( and it doesn’t work there either), do I have to change that aswell? (if yes, how? :D)

Thanks for your help again!!

I am pretty sure your problem has has to do with the gamedata and testgamemode not be overridden. Also, you should be changing a child of the original asset, not that original asset (if that picture has anything to do with the changes you are attempting in your mod). I keep sharing this around because I think it describes every step required to make a generic mod so see if there is something you haven’t done: http://pastebin.com/k91ZpGzi. Obviously you don’t need to be making a new mortar and pestle, nor are having to deal with a place able structure, but focus on steps related to setting up PrimalGameData_BP, TestGameMode, and the Mod’s umap.

The reason why you see DinoArena specifically reference the dino BP is because of the scripts written in the event graph in the dino arena call that dino blueprint. TheIsland is able to spawn dinos through the DinoSpawnEntries blueprints.

That really helped me, the references are now where they should be, but when I try to play the mod (standalone or uploaded), the game sends me back to the main menu after loading the PrimalGameData_BP. You know why I get this error?

Ok, now it loads but the roar is still the same, The problem might be that I’m unable to reference the RexCharacter_BP_C to PrimalGameData_BP.

You do so by going to the mod’s PrimalGameData_BP, scrolling down to remap NPC, select From: RexCharacter_BP To: your new bp. As for summoning it, say for example your new dino is “Rex_character_BP_Child” you summon it in game with “cheat summon Rex_Character_BP_Child_C”; Alternatively you can take a peek at a spawner inside Maps/TheIslandSubMaps/PersistentGameplaySublevel_DinoSpawns and make your own spawner in a test map.

Thanks, trying that out right now.

I’m really impressed by your willingness to help me. Could there be anything I forgot to edit? Didn’T try your solution yet, but who knows what else I left untouched.

97f5372261615127979b4c5baee611d718c1a964.jpeg That one looks good now, but maybe I have to reference that one aswell. 9769a90fc0908bbd4fbe38351a563b8bac57bec5.jpeg Tried it but still can’t find out how to do it with this one, because there is no such thing as remapping.

Oh, and my new sound blueprint isn’t referenced aswell. (at least not right I think)

3b70bc6ab1287dab079a6943b5acd338c61a455a.jpeg

Any ideas?

Once I am back at my computer I can give a closer look but open up your game data blueprint child and in the search at the top type in “remap” without quotes. You’ll see one for remap NPC. Then click add entry, open up the drop down, in from select the original game Rex, in to put your new Rex. I don’t know exactly how far this remap goes but at a minimum I believe it fixes the Dino spawners on the islands, may not fix the other problems you have. Also be sure you are testing and spawning your Dino using the command I gave earlier in the thread.

On the test map the summoning along with the sounds is working, but on the normal map (whether I use the unedited one or the new “generic” one I moved into the mod folder) I can’t summon the rex.

Double check the three things you need to change for your map (GameData override test game mode override and map override), ensure that when you are cooking the mod you selected your map not the island, and after cooking is finished go to the mod tools folder and confirm that the mod tools actually put the number of assets it should there. Lots of people are having problems with the mod cooker not doing anything even though it’ll say success.

Ah ok, i chose the wrong map at the cooking screen. But now when I try it with GenericMod as a map, it just returns to the main menu after loading the PrimalGameData.

Is there anything wrong with my settings maybe?:
Unbenannt.JPG

Nope, as far as I understand that is just the behavior you are going to get when testing the genericmod map override when testing in editor. Changes you want to test in the editor you test on the test map with it loading your new gamedata and testgamemode. Once you are past that you set up your genericmodmap, cook it, upload it (it doesn’t need to be public if this is the first version), subscribe to it, and test it in single player.