Download

DEVKit refuses to upload any mods

Just few hours ago I was able to upload normally my files to the steam with the devkit. Then about an hour ago the devkit updated its steam files and now the uploader does simply nothing. No error messages, nothing. I even tried to restart my PC, but no luck.

Did the update somehow mess up or am I the only one having this problem?

I updated a mod about 8 hours ago. What were the last 5 lines of logs in the Status window exactly (when you click Upload)?

Did you provide it with a preview image? If it says ERROR file not found, then that is likely the problem. I just uploaded a test mod with no issue.

I don’t like feeling like I’m trying to hustle my own work, but this might help you:

Just fill in the workshop ID manually if you are trying to update your existing upload.

Thanks, I will try that as soon as I get back from work.

Also the log only says the “Upload Started” “Upload Job Command Line etc etc.” then nothing else.

Is your description super long? I found out last week if you go over the limit for the description, the upload fails.

No it’s not. It’s a test mod so everything is minimal. Also I think the problem is solved thanks to TheGuyNex useful ADK Launcher. At least it’s currently repairing the devkit and steam guard FINALLY asked for the security code which it hasn’t done for the times I’ve used the Devkit. So yeah, we’ll see once I get it repaired :smiley:

SteamCMD updated yesterday and also gave us a little trouble. We’ve switched around how it launches from the editor to fix this issue for us. You should test it out in the next dev kit once it releases (later this week I believe!).

Oh, I see. Well, it’s not working in the Devkit even after repairing it. I will now try to use the ADK Launcher in the meanwhile. Thanks for letting us know.

EDIT: ADK Launcher still works as a charm! Will be using it till the Devkit update gets out of the oven ; P Thanks TheGuyNex!

Seems like the ADK Launcher refuses to update mods. Any work around or do I just have to wait till the devkit gets updated?

Yeah I’ve been having trouble with uploading my mods through the dev kit as well. I just manually did it through ArkDevKit>ModTools>ArkModTools. Seems to be the only way so far until the problem is fixed.

Thanks a lot. Got my mod updated by using that :3

This tool doesn’t update an existing workshop item. I gave it the workshop ID, but it ignores this and only creates a new publishFileId.

Since there is no way to update our mods right now, via the kit or any other tool, can you give us a more firm ETA on when we will have a new Kit with this working?

Thanks!

Do you just select ‘Create new mod’ and fill out the fields with your existing mod info? Seems to be the only way but Im just worried about creating a second upload of my mod :slight_smile:

That’s what I did and it updated my existing mod. So at least worked for me :3

I had trouble because my steam password has spaces in it (ex: Some Thing), because it gets passed in the comand line for steamcmd.exe it breaks the parameter count. So I entered my password with double quotes. It gets added to the command line verbatim, so it worked.

For example, if the password is: Some Space
Enter this as a password: “Some Space”

That got mine working.

Thursday is when I’m expecting it to go live.

Im getting a “Login Failure: No Connection” Error while ‘Uploading Content’ via steamcmd. It does say logged in OK a few lines previous so not sure what is wrong