Download

Devices in Device Manager but not Launch Drop Down List?

I’m trying to deploy to a Moto G (using UE4.5 preview). After installing the driver manager from Motorola on Win 8.1 everything works fine. Device shows up in the device manager of UE4 and deploying and running an empty scene works without issues.

However, I can only select the plain device in the launch drop down. The UE4 device manager also shows this phone with ETC1, ETC2 and ATC. The console popup on the phone shows that it is capable of ETC2 and ATC. But I can only select the plain device in the launch drop down, no ETC2 and no ATC.

Am I missing something or is it because it’s not an officially supported device? Any workaround if so?

The drop down no longer shows the texture formats supported, instead the Android option will select the ‘best’ texture format to launch - so it will cook either ETC2 or ATC if that is all the phone can do.

Is there a way we can verify this Bobvodka? My log continally states the Profile is building for Windows, even though I’m trying to build for Android.

LogInit: Version: 4.5.1-2336687+++depot+UE4-Releases+4.5
LogInit: API Version: 2326478
LogInit: Compiled (64-bit): Oct 21 2014 22:32:40
LogInit: Compiled with Visual C++: 18.00.21005.01
LogInit: Build Configuration: Development
LogInit: Branch Name: ++depot+UE4-Releases+4.5
LogInit: Command line:
LogInit: Base directory: C:/Program Files/Epic Games/4.5/Engine/Binaries/Win64/
LogInit: Rocket: 1
LogTaskGraph: Started task graph with 3 named threads and 4 total threads.
LogOnline:Warning: No default platform service specified for OnlineSubsystem
LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
LogInit: Object subsystem initialized
LogConsoleResponse:Warning: Skipping Unknown console variable: ‘UIScaleRule = ShortestSide’
LogConsoleResponse:Warning: Found in ini file ‘C:/Users/David/Documents/Unreal Projects/SantaGameMerged/Saved/Config/Windows/Engine.ini’, in section ‘[/Script/Engine.RendererSettings]’
LogConsoleResponse:Warning: Skipping Unknown console variable: ‘UIScaleCurve = (EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=0.666000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=None)’
LogConsoleResponse:Warning: Found in ini file ‘C:/Users/David/Documents/Unreal Projects/SantaGameMerged/Saved/Config/Windows/Engine.ini’, in section ‘[/Script/Engine.RendererSettings]’
LogInit: Selected Device Profile: [Windows]
LogInit: Applying CVar settings loaded from the selected device profile: [Windows]