Device crash on " Open Level "

So i’m testing my game on IOS, currently my game has 6 level, the main menu level and 5 playable levels, i package all my levels, i can access them in the device however, only through one level (Level 1) the way i’m doing this is by a box trigger (on overlap - open level). Through the " Main Menu " to " Level 1 " to " Level 2 " work great but when i’m on " Level 2 " to go to " Level 3 " and beyond the game crash on my ios device, i package the level individuality and work great no crashes, i put all of the level box trigger in level 1, package the game with all the level and from level 1 i access all the box trigger and open level without any problem.

I’m a missing something on level 2 and beyond or is this a bug ?

Also it work on the editor, Stand alone ect.

Hi Juanjose09,

Unfortunately I have not been able to reproduce this on my end thus far.

  • Have you tried the troubleshooting steps listed on either of these pages?
  • What steps can I take to reproduce this on my end?
  • Have you tried this in a clean, blank project with no additional content or is it limited to one project?
  • Can you show me a screenshot of how you are setting up your level switch?
  • I don’t have problem packaging the game it just crash when switching level

  • I don’t know i’m doing it very simple and straight forward (Box Trigger - OnOverlap - OpenLevel) On the screenshot i got a widget but i also eliminated the widget and connect the " Overlap " with "OpenLevel " but keep crashing with or without the widget . Also the GameMode i’m using on level 2 through out level 5 in on NONE, i switch the GameMode as the same as level 1 but din’t work the game keep crashing.

  • Yea i tried a clean map but keep crashing.

The name are correct, pretty much everything is set up right because on Level 1 i can switch to any level but when the box trigger are in a different level the game crash even trying to go back to level 1.

Can you post your crash logs here so I can take a look? You can find how to get the logs from the Mobile Troubleshooting Guide listed above.

Here’s the log.

What specific phone/OS are you packaging for?

IPhone 6 9.3

Can you send me your project? I’ll be happy to test this on my end and see if I can reproduce the error or see what may be occurring.

Do you have a private email ?

You can send me a private message on the forums by going to https://forums.unrealengine.com/member.php?49-Adam-Davis

Any Update ?

Hi Juanjose09,

Please give up to 4 days to allow us to properly test a potential bug. If after 4 days you have not heard a response, feel free to bump the thread once.

I have been looking into this error on my end. Unfortunately, the project you have sent does not package. There are numerous warnings and compilation errors, predominantly centered around the player character blueprint. Please try fixing these errors and packaging again to iOS.

I’m aware of the warning but those are not related to the issue about opening levels crash, i don’t have any issue packaging the project maybe i miss a file that preventing you from packaging the game or that error is happening in your end, delete the file if the you think that’s preventing you from finding the bug on open level.

The errors I am getting are all tied to the character blueprint you are using. Can you resend the project with all assets that are utilized? This should allow me to check the packaging issue without the errors I’m seeing.

Hi Juanjose09,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Here’s a update, i fix all the warning that gave me when packaging, but no luck it still crash, I created 10 new maps and work fine unti it get to the 3 map, when switching to the 4 map it crash, however now i can switch from 1 through 3 back and forward ¿Progress? I read from a couple of people who are having the same issue that a texture or a material was causing the crash when opening level but I can’t find anything that may cause the crash. The crashlog say something about LogMetal : Loaded a non-offline compiled shader ( will be slower to load ) but it wont tell me what it is. I also think could be a texture or a material since i got performance issue after reading a document about mobile have a size limit according from the link below

Unfortunately I cannot send you the project again with all the assets due to the reason my wifi card in my computer got damage due to power shortages and my computer don’t have a phone/internet cable plug, to plug in.

Can you send me a copy of your dxdiag? To get this, go to your windows start menu>Search>dxdiag and press the “Save all information” button.

In LogMetal : Loaded a non-offline compiled shader ( will be slower to load ) how do i know, what it is thats is being loaded slowly ?

After looking at your logs, I believe you are running out of memory, either on the device or on your pc while launching. What size textures are you using in the project? Have you tried removing your materials folder from the content browser, then trying to launch to see if this makes a significant difference?