Download

Dev Kit Crashes On Copying GenericMod Files

Hello, Me and others have been having this one problem with ARK Dev Kit.

The main problem is when you copy or make a child of the GenericMod files, after you pick how you want to copy to your folder in side the folder “Mods” it will crash,

I never use to have this problem with ARK Dev Kit, I have used the software before, and I have copied these files before so I know its not my computer.

I was going over “The Wookie” YouTube channel for mods and on his second video someone was having the exact same problem as me.
(grate channel by the way vary easy to fallow)

I don’t have any antivirus, i do have windows firewall, and that’s it, I have Skype up, Dropbox, and Nvidia, running.

I just want to bring this to your guys’s attention so it can get fixed faster.

Please elaborate on your understanding/meaning of a “crash” as it relates to your post/issue…

-WM

If it actually ends the program it is a crash. If it just takes “forever” then it is not a crash. My experience was that it takes forever to copy something as it does all sorts of stuff in the background. Check the task manager and the hard drive activity.

The ADK certainly can crash at copying files, but if you are copying clean genericmod files, the chances of a crash are very slim.

Are you sure the program is crashing? are you sure your system is not running out of resources and terminating the program? the first time you run the dev kit it will open up all cores and begin asset detection/shader compilation, dev kit can take 4gb of ram just to open and run, and that is without opening and editing data and loading more memory into ram.

If it is crashing, take a screenshot so people can see the error.

Sorry it took so long to get back, I am recovering from surgery.
What I mean by crashing is “Not Responding”, It will jack up the CPU usage when it dose it to 100%.
I still have not found the source of the problem however I do have a quick question.

Q: do you still need to link the Guthub account to access the soucecode for Ark Dev Kit, The program seems to function without the source code however…
I am starting to wonder if this may be the problem.

I have been having problems getting the code i keep getting a 404 Error I have done exactly what the page below has said, some people say give it a bit or so and try again so I am doing that now. Unreal Engine 4 on GitHub - Unreal Engine

Last thing I have used this program before and I know my computer can handle it CPU wise so it should not be that high when it crashes (Not Responds)
If anyone has some troubleshooting ideas I can try please let me know thanks.

I had 4GB before I upgraded my computer I now have 6GB Ram. and yes I do have to terminating the program it just stays as (Not Responding) and never responds again after.
Also before I do anything I let the shaders load and the directory be discovered.

ARK CENTER USAGE 1.png

91febfbfa18659c74cc3002edf55cc7ad6b77a11.png

God, I’m so used to seeing W10 I needed to remember what 7’s task manager looks like… anyway, Applications doesn’t show you everything. If the CPU usage is getting pegged at 100% I am entirely confident in the Processes tab showing you multiple shadercompiler.exe process running which accumulate in total to peg out the CPU(where the DevKit process itself will usually consume about 30-40% while this is happening) or judging by your system specs it could just be the DevKit using the CPU at that point.

When was the last time you used the DevKit? Also, ignore github you only need the launcher to keep the DevKit up to date.

The fact that this only happens when you try to copy or child the GenericMod files and the DevKit is not actually “crashing” - Not Responding with the DevKit is not a crash(that is just Windows telling you the program cannot respond to commands currently) you will know a crash when it happens, the DevKit will either CTD(Crash To Desktop) immediately or throw a message then close - this is just the normal behaviour of the DevKit. By trying to access the GenericMod files - which have references built going back to almost every file in the DevKit - it’s going to take a while especially with your systems specs(I don’t really know anything about AMD’s processors or if that particular one has hyper-threading(or AMD’s equivalent)) to fully load the reference tree in.

Have you tried to just start it, attempt to copy the GenericMod files and just leave it…? Oh, and 6.7GB’s of physical memory being available really is not good, the DevKit needs RAM - and a lot of it. When I run it and load a PrimalGameData - and admittedly I have a beast of a machine to work with (2x 6-Core Xeons, 64GB’s RAM and a PCIe SSD) - but the RAM usage will spike to about 4/5GB’s alone for the DevKit once it’s loaded things into memory, it’ll slowly dump this back into the cached/compressed memory with W10’s aggressive memory caching and settle around 1.5-2GB’s during usage with the “System and compressed memory” ballooning to about 3GB’s.

-WM

Thanks for your reply, good to know this stuff before I ruin a decent computer :slight_smile:

last time I used Ark Dev Kit, um I think the download size was around 45GB at the time or maybe 50GB it feels more in the 40’s it was last year around the time I got ark, so when they had that sale one, I rely have no clue, my friend purchesed the game for me last year, and I am new to steam, so I have no clue even where the date I got the game was, but no longer then a year I last used Ark Dev Kit.

I am currently saving up money for a new computer, I am still debating on saving up 2k or 1k or 1.5k for a system.
Any ideas on what I should get for a good gaming / personal computer, or hardware that will support Ark Dev Kit?
I have someone in my city that I have good rep with so I may get a few dollars off or so.
but I was planing on getting something close to below.

Motherboard: Asus Z170M-E D3
Ram: 16GB DDR4 2133 MHz
Hard disk: 1TB 7200rpm
OS: Windows 7 (I will get the computer with nothing on it then install it my self.)
Drive: DVD R/W
CPU: Intel Core i7-6700K
Power supply: 600w or (what ever they put in to it that works.)

give or take with tax for that I am looking around $2015.99 with tax but
again that is with some other place not with Business World.

Would below be plenty to make mods or should I try to find better parts?

Motherboard: Asus Z170M-E D3
Ram: 16GB DDR4 2133 MHz
Hard disk: 1TB 7200rpm
OS: Windows 7 (I will get the computer with nothing on it then install it my self.)
Drive: DVD R/W
CPU: Intel Core i7-6700K
Power supply: 600w or (what ever they put in to it that works.)

I have the same problem, I tried copying the files and the disk goes to 100% usage and the dev kit just doesn’t respond, seems to be an io lock problem. Not a good first impression if something this simple doesn’t work :frowning:

To everyone who is having problems, if this is your first time copying those files, it will take about 30 minutes. The dev kit decides to compile every single shader in the game, and depending on your RAM/CPU/GPU this can take a while. I’ve got 16GB, 6600K OC@4.2GHz, and R9 290, it took about 10 minutes to compile all of the shaders, though I know it can take even longer. It will say it’s not responding, but it’s working. Let it sit. You will only have to do this once.

This is fantastic. I just tried to copy a file, it took forever. Now I right clicked a file and guess what ^^ … it takes forever! ^^ … … AMAZING. And, nono, I don’t need any info on what is going on … I’ll just sit and wait. Now this is an Epic expirience facepalm … and this thread is over 2 years old :wink: