Download

Dev kit changes - Adding structures and items

Hi all,

I used to mess around with the ADK a while back and had no issues adding in new items or structures to the game but coming back after a 2 year break I can’t seem to get my head round a few things. I have added two shields, one helmet a forge, smithy and one new resource.

In the editor the Engrams show fine, I can learn, spawn and place the two buildings and the armor works okay too. Once I cook the mod and boot into a single or dedicated session the Engrams do not show, I can spawn all the items but cannot place either building down (They do not even show to be placed, nothing happens when clicking the hotbar).

So iv been over the basic things I could remember from old;

Engrams are added to the Additiional Engrams BP List

Tried with and without the main BP structurs added to Additional Structures To Place

PGD points to my copied game mode file.

Map is linked to the PGD using the override and theisland removed form the Force Load Map Name – read two different opinions on still needing a gamemode for a stackable mod and removing the map name?

I think that was about all, anyone have any pointers or can think of anything missed?

Thanks,
Izion

You only need to use a custom game mode if you in fact are editing the game mode. If you are not changing anything in the game mode, you don’t need one. Use the default vanilla gamemode
The structure bp’s (ones with the mesh) MUST be in “Additional Structures to Place” or you won’t be able to place them
“Map to Load” line should always be blank
Make sure “Consumes Primal Item” on the structure BP is pointing to the correct primal item and be sure the primal item is calling the correct structure to be built
Lastly, make sure the engrams are also calling for the correct primal item

Hi P0k3r, all this seems to be in order now but still no luck. I going to start fresh and see what happens. Just to confirm though the default game mode is Testgamemode not ShooterGameMode?

Thanks for your help,
Izion

testgamemode

Thanks P0k3r, started fresh and all working now :slight_smile:

Does my mod game mode need to be a child of “testgamemode”, or a copy? Having the same issue, been at it for days now.