Download

Dev build doesn't run on development machine, but will on another?

I’m using the Shooter Game project as a starting point for a game I’m currently working on. Everything works fine when I run it from the editor, but when I create a development build to test things out, it gives me a black screen and the music from the intro video. The really weird part is that I can put the build onto another system and it works just fine. I’ve been able to get an early build to work, but I’ve started over a couple times. My graphics drivers have been up to date, and nothing has changed on the development machine between the time a working version worked and now. Anybody know how I might be able to fix it?

Development machine specs:

AMD Athlon II x4 620 CPU @ 2.6 GHz
8GB DDR2 Memory
EVGA Nvidia 750SC (2GB)

Specs for laptop that can actually run the game:

Mid 2010 MacBook Pro
Intel i7-2720QM CPU @ 2.2 GHz
4GB Ram (DDR type currently unknown)
AMD Radeon 6750M (1GB)

Okay, so… I just realized the problem is the loading video itself. I removed it from the Movies folder in the game’s content directory, and it works. So… new question. How do I resize the video? I can only assume it’s due to the resolution size cause it’s much larger than my monitor’s resolution can handle.

Okay, so since last night, it seems the development build doesn’t want to work, again. Nothing has changed since last night. Anybody else having this problem?

UPDATE: I found the culprit! Development builds hate Steam. I disabled it and now it works with no problem. I was even able to recreate the problem on my laptop. I’ll leave this here in case anybody else is having the same problems I was.