Dev build crashes, Shipping doesn't build

Hey guys,

I wanted to test my product so far (which is just a menu with a host and find servers button) and tried to build it.
First I tried a ‘shipping’ build, but that just fails to build.
Here’s a link to the output log: Error log Shipping Build -

And when I try a developer build, it builds but it give me the following error on startup:

The UE4-project_savannah Game has crashed and will close
Assertion failed: Class [File:Runtime/CoreUObject/Public/UObject\Class.h] [Line: 2563] 
ConstructObject called with a NULL class object

KERNELBASE.dll!UnknownFunction (0x000007fefd60aaad) + 0 bytes [UnknownFile:0]
project_savannah.exe!FOutputDeviceWindowsError::Serialize() (0x000000013f5aff1c) + 0 bytes [UnknownFile:0]    
project_savannah.exe!FOutputDevice::Logf__VA() (0x000000013f38c258) + 0 bytes [UnknownFile:0]    
project_savannah.exe!FDebug::AssertFailed() (0x000000013f3686c9) + 0 bytes [UnknownFile:0]    
project_savannah.exe!UGameEngine::Init() (0x0000000140ec9325) + 0 bytes [UnknownFile:0]    
project_savannah.exe!FEngineLoop::Init() (0x000000013f2b00a9) + 0 bytes [UnknownFile:0]    
project_savannah.exe!GuardedMain() (0x000000013f2af1ca) + 0 bytes [UnknownFile:0]    
project_savannah.exe!GuardedMainWrapper() (0x000000013f2af3da) + 0 bytes [UnknownFile:0]    
project_savannah.exe!WinMain() (0x000000013f2bfa59) + 0 bytes [UnknownFile:0]    
project_savannah.exe!__tmainCRTStartup() (0x0000000141d3b1e5) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]    
kernel32.dll!UnknownFunction (0x00000000773c59cd) + 0 bytes [UnknownFile:0]    
ntdll.dll!UnknownFunction (0x00000000775fb891) + 0 bytes [UnknownFile:0]    
ntdll.dll!UnknownFunction (0x00000000775fb891) + 0 bytes [UnknownFile:0]

Help would be appreciated here, thank you.