Download

Destructive Objects

So last night I was making a wall that you can run through to attack AI on the other side of the wall. It worked until it crashed this morning and had to start over. Following the same steps as before, unable to recreate this affect. I click the simulation generates hit events, and collision presets are set to destructible. Any advice for me please?

Hi a548922,

When you had the crash occur, did you have the checkbox next to “use async” set to checked or unchecked? There is a known issue with the use async feature that is being assessed currently. Thank you!

Was the destructible inside a blueprint? There was an issue with this which has been fixed, but the fix won’t be rolled out until 4.2

(The fix is in github if you’re compiling from source)

I created blueprints, as well as did not have the use async clicked. Simulation Generates Hit Events is clicked. It took restarting the computer three times, and rebuilding the entire project three times to get it to work. The only issue i have now is when I shoot an object, the entire wall explodes, instead of just the part of the wall i shoot. Anyway to fix this? Tried hard sleeping clicked, but it was to hard to knock the walls into pieces.