Download

Destructible mesh + overlapping collision = boom. How to fix that?

Let me explain what I mean by this pretty picture:
prettyPicture.jpg

In my case I have a wood/stone railing that I want to be destructible. It works, but destructible mesh explodes upwards even if there’s no force/impulse added (both set to 0) - however, when mesh floats in air (not overlaps anything) then it works as expected: It just falls apart with no ‘explosive’ effect.
My railing meshes are buried a little into other static mesh (not destructible) structure, because they’re… Railings, so it’s natural :slight_smile: . Is there a way to fix this unwanted ‘explosion’?

hey
you could adjust the collision mesh so the part that should clip through the ground isnt part of the actual collision mesh. backside of this would be that after destruction the part of the model without the collision mesh would be visibly clip through other geo too. in other 3d apps there are options to control the distance between collision meshes whenever they should physicly interact with each other. with this you can stabilies simulation so they dont explode without force. i dont know if ue4 has something like this?

You can set a minimum Impact Velocity Threshold, in the advanced “Damage” details, in the destructible mesh settings. That should stop it from exploding, though the overlap will probably still affect how it fractures. You can also check the “World Support” flag, which will make the overlapping chunks stick to the static meshes.

Thanks for the ideas,

It would be really handy. But I can’t see aything like that in UE.

I’ve tried setting the Impact Velocity Threshold to different values (even really high, like 100000) but it doesn’t seem to do any difference.
What’s strange, checking “World Support” also doesn’t work. Chunks that overlap with other static mesh don’t stay in place (just like they should?), but still explode upwards. I don’t have “Asset Defined Support” selected, so if I’m not misunderstanding something, it should work.