Destructible mesh editor, viewport too dark

I don’t wanna sound like a whiny baby here, but I’ve been messing around with destructible meshes at first using PhysX Lab and importing but ran into issues. So now, I’m using UE’s built in DM editor. I can’t see anything because the background is completely black, making it a bit hard to work with. I searched appearance in editor settings and couldn’t find anything helpful. It’s not a huge deal, but I’m just curious if there’s some setting where I could either change to another color for BG, or add an atmosphere of some kind. If it’s something that will have to wait, I’m not going to complain :wink:

~UE4 FTW!!!

I realize for now I can simply apply materials to the objects AFTER I create the destructible mesh. Easy enough.

You should be able to hold L and left mouse click to move the light around in the viewpoint to shift it better for your need.

Let me know if that doesn’t work for you.

Hello kind Sir and thank you for the answer. I am able to move the light around, I can see the light reflecting from my metallic object, but seems to have no effect on the object’s color. I don’t mind using an unlit or brighter material while working w/ the DM then changing when finished, so I can use that workaround for now. If there’s anything you’d like me to try just to troubleshoot more, however, I’d be happy to .

I’ve got the same issue. I can hold L and left-mouse-click the light around, but the viewport is still so dark. Anybody know how to brighten up the viewport?

It’s still way to dark.

Yes it is unusably dark. Sort it out Epic.

+1, at least give the option to add a background

Bumping this because it’s still very dark. I wonder how Epic uses it? I can barely see a thing in the DM editor

Engine\Config\BaseEditorPerProjectUserSettings.ini has the lighting settings used by the destructible mesh viewer under [/Script/UnrealEd.DestructableMeshEditorSettings]. Note that these are used by several other viewers (SAnimationSequenceBrowser, AnimMontageSegmentDetails and SSkeletonWidget).
For some reason, the code that enables editing of these in the preferences UI is commented out (see RegisterContentEditorsSettings in EditorSettingsViewerModule.cpp)

However, the reason most of the screen is black is because the widget is just hardcoded to have a black background. If you can modify the source, you can change the implementation of FDestructibleMeshEditorViewportClient::GetBackgroundColor() in Engine\Source\Editor\DestructibleMeshEditor\Private\SDestructibleMeshEditorViewport.cpp to return a value other than FLinearColor::Black.

Same here, its pitchblack for me.

Yeah it’s way too dark in the physx editor also…Pitch black.

Any way to set a world light or throw in a background image? I have to constantly rotate the light around and it’s still hard to see stuff. To edit shapes I have to turn off lights and rendering and work within the wireframes. The wireframes are too black also. I don’t have access to edit the source on my end.

Any plans to address this soon?

  • 1 for me, this really needs a fix

Way too ■■■■ dark.

Is this ever going to be fixed?

It’s too dark… Don’t be ridiculous Epic, do something.

Did anyone ever find a fix or workaround for this?