[Destructible Mesh Bug] Blueprint Viewport does not update with new Destructible asset when chosen on the component

Dear Epic,


Make a new actor blueprint

Add a destructible mesh component

Make sure it is the new root, removing the scene comp default

Now set a destructible asset (you can easily make one by right clicking on any static mesh asset)

Notice the viewport of the Blueprint will not update and show your new ly chosen asset!

Now exit the blueprint, and drag the blueprint into your level.

It will appear! Yay!

Now go back into the blueprint editor, and look int he viewport, you will see your asset, yay!

But now change the destructible asset of the component to a new mesh, a different destructible

The asset will not visually change!


Someone at Epic needs to make it so that the viewport updates with the new destructible mesh asset, this is either because the viewerport is not being invalidated and told to refresh… or some other reason I dont quite know :slight_smile:

#Update ~ This is a Big Issue

Instances of the destructible blueprint actor that were placed in the world will not update their asset when you pick a new one in the blueprint itself!

This really needs to be fixed!





I have been able to reproduce your issue, and have entered a bug report (UE-29575). Thank you for providing repro steps and for your report. I will provide updates on this issue as they become available.

Have a great day


We’re also experiencing this issue, in 4.12. Are there any updates or eta on a fix?


This issue is currently under investigation by our developers and is slated to be resolved in the future 4.13 release. Please be aware that this may be subject to change.

Have a great day

Still unresolved in 4.13.1.

Here is the link to the public tracker so you can keep an eye on the status of the bug: Unreal Engine Issues and Bug Tracker (UE-29575)

Have a great day

Found a workaround for this!

If you toggle the “Editable when Inherited” checkbox on the Destructible component inside the blueprint, it will make it show up in the viewport!

I’m guessing toggling that checkbox triggers an refresh somewhere. Not the greatest workaround but much better than readding the blueprint in the world or restarting UE4 :slight_smile:

omg thank you. I just encountered this problem too!

Thank you man, we were freaking out when trying to get the destructible to work!