Destroy Actor no work

I transferred my project from 4.8 to 4.9, all “Destroy Actor” in my blueprints no longer work.
When run it (any type of object) I have the following message:

"Error Can not access’ … ’ It is pending kill. Property: … "

What has changed?

Can you post a snippit of one of your scripts. It looks as if you are trying to access an object that is destroyed or in the process of being destroyed, can you try setting the auto destroy when finished boolean flag on the actor to true?

I use it in many points of the Level BP and are differnt type objects(static,skeletal,text,blueprint…):

And in Character BP:

All “Destroy Actor” in any situation(and for any object type) return the same error:

Everything works perfectly without error on the 4.8 version.

Allow your actor to be auto destroyed.

  • overall the issue i see is that your projectile is destroyed or in the process of being destroyed and you are trying to do something with it. Have you tried debugging your blueprint?

  • Will it help if there is a small delay before spawning the new instance?

I’m sorry, I don’t understand what you mean …
How I to allow the actor to be auto destroyed?

That’s happened to me too, Is there solution yet?

what about increasing the delay of the destroy?

Thank you Daniel for this. I don’t know what Functional Test Reference is, so I haven’t used Register Auto Destroy Actor node, but I found out there’s a possibility to just get or set “Auto Destroy when Finished” inherited variable inside an actor. So instead of using Destroy Actor or Register Auto Destroy Actor nodes I just set “Auto Destroy when Finished” to true and it worked like a charm.

In my case I destroy the actor at the end of my operations on it, but I guess some of them probably take longer to execute and they are still in progress when I destroy it. So that’s why I was getting an error (the game still worked as intended in 4.9, but with errors in the log).

If someone still has this problem, then check out this solution as well: 4.9 Has Broken my game! - Blueprint - Unreal Engine Forums!