Derived Data Cache is no longer created


I’m using an SSD for the OS and for more important stuffs. It’s capacity is rather limited (100 GB) and after a while I saw that UE puts the Derived data cache files there (10+ gigs). So I tried to relocate them but I couldn’t find clear instructions other than “edit the engine ini”. Well thanks… there are 7 different engine inis at different places. I tried to edit them one by one and see what happens, but non of them helped. I thought the problem might be that the old files are still existing so I deleted them. Now it won’t create new ones at either location and loading up a project or different maps takes ages.

Hourence says “add following lines to your default engine ini”. I would expect this to be the ProjectFolder/Config/BaseEngine.ini. Adding those lines makes no difference, I guess that’s because of the new way UE uses the ini. If I know it right it writes out only the changes, but the code is different.

I also tried to modify the ProjectFolder\Intermediate\Config\CoalescedSourceConfigs\Engine.ini and ProjectFolder\Saved\Config\Windows\Engine.ini. No results. I also edited the one in the install directory of the engine: D:\Program Files\Epic Games\4.7\Engine\Config\BaseEngine.ini but I guess that’s for new projects. Existing ones won’t check it after creation.

If somebody could point me to the right file and what to modify there that would be great as it is a real pain to work now with loading times going up to 30 minutes.


Works for me. I had to change the quotation marks though. If you copy this straight from Hourences, it will use some odd quotation marks that the engine can’t recognize. So it ignores the override command. Just replace it with proper quotation marks like these " " :slight_smile:

Yaaay! You are a life saver. :slight_smile: Thanks!