Download

Deploying to Android with c++

Hello,

I tested deploying the side scroller (blueprint) to my android nexus7 and it runs great, however anything i try to deploy with c++ fails. Am i missing a step?
Thanks

Question, what are the tools needed to put on android?

https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/index.html

Ah yes, thanks for that. So would C++ make the game performance any better on android from instead of just using blueprint. It could due to less over hang I guess.

The docs are straight forward and nice :smiley:

Hi jldevoy,

What deployment workflow are you using (Launch On, File > Package, etc.), where in the workflow is it failing, and what error are you getting?

EDIT: Also, are you using the editor downloaded by the Launcher or compiled form the GitHub source?

Which method did you use to install the Android SDK/NDK? What’s your NDKROOT environment variable set to? (open a command prompt and type ‘set’ to see env vars)

I used the supplied Nvidia installer above and blueprint samples deploy fine, only c++ samples fail. I’m using the supplied editor, i will probably never look at the full source code.
I run launch, select new project…choose one with c++…and deploy will fail. I suspect it’s something to do with the way selecting a c++ project starts you in VS instead of unreal editor and you need to run the project to get the editor.

There is a known issue right now that some required AutomationScripts may not be built automatically. To correct this, open your solution file in Visual Studio and expand the Programs > Automation folder. Set your environment to Development Windows and build each of the .Automation scripts in that folder (it should only take a few seconds to build each one). Please see if that allows you to deploy.

EDIT: The AutomationScripts issue is for the GitHub version. Taking a look at Launcher version now.

Also, for future reference, when you run into bugs, please report them to the UE4 AnswerHub in the Bug Reports section so that we can better investigate and track the issue.

I have no such folder in my c++ solutions; possibly the cause of my problems.

No, that was my mistake. I’ve been bouncing back and forth between the GitHub and Launcher versions of the editor a lot lately. Sorry about that.

I’m having trouble tracking down exactly what you’re running into right now. Would you mind posting your issue to the AnswerHub site so we can get some more eyes on it? It may be helpful if you could open the Output Log (Edit > Output Log, or click “Show Log” on the deployment process notification) and include the actual error messages you’re getting.

I think the giant debug log is putting people off looking at the thread on Answerhub :frowning:

I formatted your logfile and highlighted the necessary error messages. We’ve seen that error occur intermittently and are investigating a solution.

I have the same Nexus 7, works fine with any blueprint project, Epic sample or my project. But I get the same error when I try to deploy sample with c++
I take a look at your log Jldvoy, seems to be the same error.

[xpost from AnswerHub]

I’ve fixed the problem and will be in an upcoming hotfix (not sure if the next one or one after).

Turns out we had a bug when not using Incredibuild (which we have here at Epic). For home users without Incredibuild, there was a null string. Easy fix once I could repro :slight_smile:

Josh

Perfect. My primary target for testing is pc but it’s great to see prototype on others plateforms.

How to fix it?

The fix is coming soon in a QFE, but you can install a free trial of Incredibuild to make it work until then :slight_smile: (Someone figured this out on Could I get some help with successfully deploying to Android? - UE4 AnswerHub )