Download

"Deploying content for launch" taking a long time

Testing the deployment to my android device (S3) and installed the samsung USB drivers and SDK. The device appeared in the engine, in fact a ton of devices appeared in the engine - some followed with abbreviations ATC, DXT, ETC1, ETC2. I tried the first one without abbreviation.

It went through a lot of log entries before finishing with this:

Though it still says “deploying content for launch” with the loader ticking away and not doing much else. I’m just wondering what I’m missing here, the game is definitely not showing up on the device. I’m assuming I should not be copying it manually over (lol).

I just tested with the 2nd abbreviation and it’s still the same (though it did compile faster this time of course). Any ideas?

Update: The above “hanging” issue, seemed to be caused by USB debugging not being active. However now there is a different problem, it can’t load the game properly.

After activating USB debugging, I began to see a “UE4 game” program come up on the phone. However, no matter which project I try (Swing Ninja, first Unreal demo project etc.), it pauses a second (trying to load it) but then immediately quits to the home menu. This is kind of strange, as I can play other games on the S3… (PS1 emulator etc). Any ideas what may be wrong?

Update II: I’ve tested it with my Google Nexus 7 and after switching to P2P usb mode (camera) it all works perfectly. Ace! However my S3 still does not work. I think it is Android 4.3. The Tegra dev pack installed API for 4.4 - does that mean all 4.3 devices do not work? Or what else could be the problem? S3 should have more than enough power to run some of this basic stuff. I’m going to try re-install tegra with more APIs. Hope someone is reading this :slight_smile:

Hi RodenJP. The “hanging” problem you mentioned is a known issue, and making adb’s waiting state more obvious is a feature we’ve requested from the platform team. So far, we have only tested the latest Nexus5 and the GalaxyS4, so no other devices are officially supported yet. Moving forward, we will be expanding the breadth of our device testing, and will officially support more devices moving forwards. As to which devices, in particular, we will be supporting, I can’t speculate on.

Also, the various abbreviations you saw are the texture formats supported by different Android devices. If you know the particular formats your specific device supports (eg. ATC for the Nexus5), then you can cook just that format. Selecting the non-abbreviated option cooks all of them; good for broadest compatibility, but can greatly extend your cook time.

Brilliant, thanks for clearing that up! Yes I was aware mobile support was a little rough so it’s understandable.

I have just tested again after re-installing tegra with more APIs (Android 4.3 etc - how does this affect the launching process btw? can this be configured before launching regarding which one to use?). Anyways, with the default launch settings, the S3 (4.3) just doesn’t respond “UE4 game has stopped responding, wait or OK” when the screen is turned on. If you turn it off, attempts to access the game just take you back to home screen after a split-second pause.

Also the S3 is only detected by the cmd “adb devices” when in MTP mode, in contrast to the Nexus 7 which is only detected by the same command when in P2P mode. What this means I’m not quite sure yet. :slight_smile:

Hi! Yeah, I’m having the same issue with my Galaxy Tab 10.1. I included all of the APIs when I installed Tegra…

Yeah I haven’t come across a fix yet. It’s probably a bug that they will work on soon. Will let you know if I manage to fix it myself though…

Have you run “adb logcat” to get the log? “adb logcat -s UE4 -s Debug” should give a nice concise set of logs that will hopefully shed light on the subject…

Nope, I’ll try it. But I imagine it’s something else since the game appears in the app list and works on Nexus 7 but not S3.

For however is reading this: try putting your USB cable in the backside of your desktop rather than in the front. I had a lot of issues trying to deploy to an Android device. The editor just hanged and nothing was outputted. It is mentioned in this post that there is a waiting state that keeps waiting without any extra comment. The extra cable needed from the front USB to the motherboard was having some issues. When I used a back USB port, it all just worked fine. Both used USB 3.

No idea why but front USB ports will not work at all with android dev on my pc either. The editor can see the phone and do everything but deploy the app.
It would get stuck at

Once changing the phone to the back port i noticed it would get past this part.

Does anyone know why this is the case? In Fact it works on my usb pcie card just not the usb controller through the motherboard’s usb3 header. Very strange.