DemoNetDriver/Replay Stuck

Effected Versions I tested - 4.16.3, 4.17.1, 4.17.1 (git)

Followup on “fixed” bug that still persists without crash - Unreal Engine Issues and Bug Tracker (UE-42508)

If same console commands are executed in console, replay works as expected.If same series of commands are executed from BP or appropriate c++ equivalent, replay camera is stuck on 0,0,0 unable to move or rotate. Physics actors are moving, but taking different paths than in the recorded demo. (Despite their movement being replicated)

Steps to replicate:

  1. Create third person project

  2. Add this blueprint to level blueprint

  1. Play in standalone

Issue is present in 4.18 preview 1. Bug occurs in both standalone and exported build.

Hey Crispy_Penguin,

After speaking with a few of our networking devs, there are a few issues that are actively being worked on/have been fixed. Unfortunately, the fixes will not be available in the latest engine version as far as I can tell.

Here is the ticket that you can view publicly: Unreal Engine Issues and Bug Tracker (UE-48320)

There is also a ticket that we are tracking internally that should add support for demos in PIE as well, so keep an eye out for that addition in 4.19.

Thanks for the report and have a great day!

Thanks, you are the best!

I have the same problem and searched the Github’s Pull Requests, then I found this solution submitted by a game dev: fix replay bug when play from 3D widget

I have tried and it perfectly solved my problem!

According to the codes, it looks like when starting playing replay, the World loading/unloading and DemoNetDriver initialization are in the different threads.

After DemoNetDriver starts initialization and before it finishes initialization, the World changes map and clear all the net drivers, which makes crash and stuck later.

Not know why in 2D UI the bug doesn’t show.