Download

Deleting collision sphere and now can't spawn.

Hey this is a bizarre one. So I have a pawn and for a while I was using a collision sphere as the root with the mesh set as a child of that. Later on when I decided to swap the sphere for a capsule, I ran into some errors.

Now I know changing the sphere to a capsule means I have to go back and replace all references to the sphere, which I did.

Here’s where things get weird.

If I press play, the player pawn won’t spawn. It used to. If I remove the the player start and set the player BP in the level and set that to possesss0, that works.

Here’s where it gets weirder.

I set a an object channel and preset for the player collision. If I set the collision to anything other than my player’s collision channel, it will spawn from the player start.

Again, everything mentioned was working prior to changing the collision sphere to a capsule in the player pawn.

The only thing I can think of is that deleting the sphere caused references to get corrupted and a clean build is necessary. But I tried that as well. I also tried creating a new project and migrating the content over. Same issue. I was also able to reproduce the problem across several projects. But since I don’t know exactly what is breaking, I’m not sure how to fix it.

Possible bug?

Are you using a Blueprint to manually spawn your character at your selected PlayerStart actor? If you’re using ‘Spawn Actor From Class’ node, try changing the Collision Handling Override to ‘Always Spawn’.

No. I’m using the default player start. I can create my own player start using the method you described and no I don’t need to change the spawn/collision parameters. It just won’t work from the default player start.

Workarounds are great but when things suddenly stop working for no apparent reason, I like to know why lol (pulls hair).

It’s working correctly mysteriously. I didn’t change anything. I did reboot the computer though. Perhaps it was something stuck in memory?