Deleting a menu widget does not appear in undo history

Deleting a menu widget does not appear in undo history

I fear I have lost all my work now.

Hello ,

When you say that deleting a menu widget does not appear in the undo history, do you mean that you have deleted the entire widget from the content browser or that you have deleted something from the designer tab? Would it be possible for you to reproduce this issue in a clean project?

Yes I deleted the entire widget by accident :frowning:

And yes, started a new project added both a “Level” and a “Widget Blueprint”, deleted each one and checked undo and undo history, nothing.

Hello ,

Have you tried opening up a back up of the project? These are created by default. The file path by default is:

C:\Users\YourUserName\Documents\Unreal Projects\YourProjectName\Saved\Backup

I have also written up a request ( UE-17578) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Yes I see my menu backups but how to I bring it back into UE ? It doesn’t open and import does not recognise it and dragging it in does not recognise it.

There are no answers from googling it either, how would I restore my menu ?


Hello ,

Have you tried opening up a new project’s content folder within window explorer and simply dragging and dropping the back up in to the content folder?

YES thank you :slight_smile:

Hello ,

Are you receiving any errors when trying to move your assets or are they just not showing up? Have you made any code changes to the engine that you are using? Have you tried moving them into a newer version of the engine?

oh sorry, I wasnt clear lol, when I said YES it meant your suggestion made it work :stuck_out_tongue: The problem is fixed, thank you.