Download

"Delete Game in Slot" returns false despie "Load Game from Slot" returning true

I’m not sure why, but it seems somehow my savegames are becoming … corrupted, for lack of a better word. I can load them and everything looks fine. But if I try to save over them, it returns false. If I try to delete them, it returns false. I thought I could load the save game data, delete the save file and re-save to un-corrupt it, but it won’t even let me delete.

I thought the reason why this was breaking was because I was modifying the struct used inside the save file. But I started a blank minimal project and tried to reproduce by modifying a struct in use by an existing save and I couldn’t seem to break it.

My last thought is that it’s something multiplayer related that’s breaking it. But I haven’t been able to reliably reproduce the issue playing with multiplayer aspects either.

Is there any better way to debug why Save Game in Slot or Delete Game in Slot might fail? I’m at a point where I’m tempted to append a “version” number to the end of the slot name and it it fails to save over the old one, increment the version and save over a new one instead. It’s a sloppy fix though and I really don’t like it.

I’m having this same issue!!!

This is many years late but I was having a similar problem with my save games.

My Save Game would selectively save and delete. Sometimes it would fail and sometimes it would work and had no idea why.

Fixed it by turning off my Dropbox syncing.