Delete Assets - Asset still being referenced


So I’ve imported a Static Mesh directly into the Game -> Meshes folder in the Content Browser, placed it in the world, and checked it over. Everything was fine until I realized that my units setup was incorrect in 3ds Max, so I went to delete the Static Mesh from the Game -> Meshes folder in the Content Browser and received prompt:

What exactly am I meant to do at point? I do not want to Replace the referenced asset with another mesh and the Force Delete option sounds like something that would potentially give me problems in a much larger scene, so how do I actually delete the Reference itself so that the UE4 doesn’t give me error? Also what’s frustrating about is that it doesn’t occur on every asset I try and delete, but I can’t figure out why UE4 holds on to certain references over others when I place Static Meshes in the world. When I Right-Click the mesh and go to Reference Viewer I can clearly see that it’s still being referenced, but I have no option to delete that reference and there is no instance of the Static Mesh actor in the Scene Outliner.

Any advice?

After deleting that mesh from world save the level and try deleting it from Content Browser.

I ran into a couple days ago. I went with force delete since I wasn’t using it anywhere in my blueprint. It horribly broke everything.

There should be some kind of third option of “Delete asset and remove all references to it”.

1 Like

I found thread because I am having a similar problem trying to get rid of assets I no longer need and that I have scoured through every blueprint to get rid of references. Does anyone have a suggestion as to how to get rid of assets and their references?

I believe has been resolved in version 4.5 (just released), reading the notes I found the following:

Otherwise you will need to edit the item that is shown when you try to delete and manually replace any references you delete. You should see a message when you try and delete an asset telling you which items will be affected. :slight_smile: