Delay nodes not always triggered

Hi! Now and then my delay nodes are not triggered/fired and everything past these nodes are completely skipped. I have a “cutscene” when the player completes a level so I need a delay before i Open Next Level. Right now ALL my delay nodes doesnt fire. Not a single one. No matter which actor…This must is a bug? Its ridicolous

Here is a screenshot from what Im trying to do! Its very simple its:

  1. Delay
  2. Add UI to viewport
  3. Open Level

Nothing happens. Nothing at all…Please tell me this is a bug

First about your delay notes. If you make a new actor blueprint and do something like “EventBeginPlay–>Delay(2)–>Print(Hello)” and place this actor to your world does nothing happen?

Ill try! But is there a way that I messed up in the delay base code somehow? I didnt even tocuh that and this worked just some days ago lol…

I am not sure because in ( https://answers.unrealengine.com/questions/736747/random-things-stops-working-all-the-time.html ) you say all your delay notes not working

I haven even changed that actor in months :frowning: So level blueprints are bad? These things doesnt work in ordinary actor blueprints either thats my problem that things only works now and then ffs :frowning:

I have to return to an old backup everythings ■■■■■■ up now. All kinds of nodes doesnt trigger. What are the chances that the project has gone corrupt or the like?

Have you tested that example in my first comment?

Ah its the same person? Oh ok lets just talk here then! Thanks alot for all your help, exactly almost everyone doesnt work. Is it a corrupt project or unreal version? It cant be like that

So this question is closed?

Ill try that now thanks

Hi again! OK so a new actor was able to use delay properly I called multiple delays with print string nodes in between. That works. The other things seem to work now as well, but that means it fixed itself just like how the error occured…Unreal wtf

I just had a similar problem in which delay nodes in level blueprints never continue after delay, as if a value of “infinity” were placed in it. This only seems to happen in level blueprints, and intermittantly.

What are you trying to delay in the level ?