Delay inside widget not running when game paused, since UE4.26


In 4.25 and below when you paused a game, delays inside a widget were still working. Since 4.26 they are paused and don’t execute any code behind it.
Is this changed on intention or is it a bug? And how can I make it behave as before since my game depends on it.

Thanks in advance

I have the same issue here, please let us now if bug or expected behavior, I’ll have a lot of UMG to update if that normal…

Same here, and really confused there is not much to find about it. Since this seems like quite the game-breaking bug or change :confused:

Oh you’re right, I didn’t noticed it yet. This is pretty important actually.

I know, right… But still nothing about this :confused:

If you don’t report the bug, nothing further will happen. Have submitted this bug under case # 00280420 now.

I have already reported this bug in December and noticed somebody else also reported this bug in actors blueprints recently and it is marked as unresolved. The serious thing about this bug is that the tick still works but the delay does not trigger. I made a sample and when paused widget tick kept trigger and everything after it worked fine but when reached a delay node in the same line stop

Pleeeease, I hope they fix this. Its been irritating me the last two days and I tried every possible alternative, in which I can’t find any good solution to fix my widgets.

I’ve submitted it as a bug with a test project, lets hope it gets noticed. I’d imagine this is a very common issue for most people.

The answer was shared on the [forums][1].

Originally posted by [andrea.b][2] [View Post][3]

Hi Guys,
I checked the code of the UUserWidget::NativeTick in 4.25 and 4.26 and there is indeed a bug!
In 4.26 they added a Console Var named Widget.UseParallelAnimation that is “true” by default.
When this cvar is true the widget blueprints won’t tick when the game is paused and it looks a bug to me.
So you can bypass this bug by setting this cvar to “false” by changing it using the console (either on the editor, in C++ code or inside a blueprint)

So my solution was to set this CVAR in my Game Instance’s Init. You could probably also call this in your Game Mode, or Game State’s BeginPlay.
Using Run Console Command.

Widget.UseParallelAnimation false

1 Like

You are a genius! Thankyou. Just saved me from hours of rethinking my paused UMGs

I put mine in game mode and works like a charm.