Default values of a structure not being saved in 4.8.3

I have a struct with four variables of a custom blueprint class type. After I set it’s default values, regardless of saving, they are set back to ‘none’ once I close and re-open the tab. If I run my game with the window open, the values are shown but the script using it doesn’t find anything. The only workaround I’ve found for this is to make a duplicate of the struct, in which the values are saved but only for the session while the editor is running.


i havent such problem with structs in 4.8.3, try create new template project (third person for example) and reproduce bug here, if it doesn’t happen, then you can try migrate needed things from your bugged project and try reproduce again. So if bug reproduces only in your project, then try just migrating everything from your project into raw new template of same type.

p.s. for everyone:

to enlarge pictures right click it and select “open in new tab”, answerhub doesn’t handle this yet in 1 click on image

don’t forget mark question as answered with little gray circle button under any answer (not comment, but whole answer) when problem solved, so anyone else later can have same question and may find solution faster, if you find solution on your own, don’t forget write it too

I haven’t had this problem yet either but maybe try setting the default values in the “Event Begin Play” or the Construction script of the object that uses it. Not an ideal situation but perhaps it will be a workaround until a proper bug report is filed?

Seems I’m the only one having this problem! Haven’t found a workaround yet but I’ll keep tryin’.