Default land movement mode not applied when the Character is spawn from BP


I was investigating my issue here Root motion issues when spawn from BP - Character & Animation - Epic Developer Community Forums and I found out that the DefaultLandMovementMode value of my Character is not applied when I spawn my Character from a blueprint. It is applied when I add it directly in the level.

I don’t think it’s a “normal” or “intended” behavior.
Will be glad to give you more infos about it if you need to.

Best regards.

Hey NymKappa-

How exactly are you creating/spawning your player at runtime? If you are using the “Spawn Actor from Class” node, the character is being created without a controller. In this case, you’ll need to check the box for “Run physics with No Controller”. This will allow the character to be spawned, and behave based off the setting for DefaultLandMovementMode / DefaultWaterMovementMode.