Dedicated server not showing up on find session

I’m using the Steam subsystem and Advanced sessions for my blueprint based project.

I’ve used this tutorial to setup my Windows dedicated server [][1]

I am able to run my server and it opens but I am unable to find it using the “Find Sessions Advanced” node although I am able to find peer to peer sessions this way.

Here are the blueprints for my current, working peer to peer setup (Which breaks if I turn off presence):

Here is what I have to start the session on my dedicated server in the “Entry” map for the server.

Here is a debug view of what I have for my find session setup:

Whenever I have my peer to peer session running, the find session prints that it can find sessions but when it tries to find the dedicated server, it doesn’t find any of them.

This is the relevant part of what I have in my DefaultEngine.ini: [][5]

These are the logs from my server when it runs: [Server log - 317f6b37][6]

I have port forwarded 27015 and 7777 which are both TCP and UDP although, I think it doesn’t even need to be setup when you’re going through the Steam subsystem.

I can however get the server working if I don’t go through the Steam subsystem by adding “-nosteam” to the launch perimeters of the server, port forwarding and then connecting though the IP instead but it still doesn’t come up in the find sessions node.

The server only shows up in the “View > Servers > Internet” part of steam when I use an appid of 480 but if I use my own, it does not show up which I think is just because the game is set as being hidden in the steam database but it shows up either way in the LAN tab. Using the 480 appid does not fix the find session node though.

Thanks for the help.

I have similar problems and have been trying to get our full up game to have dedicated servers.
I wrote this but can no longer edit it because the page says edits are suspended for server changes or some such. (7/3/2018)

Getting a dedicated server working requires a zillion things to be exactly right.
For testing I made a super simple sample game, and then made a dedicated server build for it.
It is appid 480 which is the Steam sample game appid people use for testing.

The test lets one run a game dedicated server and then see it on the steam server window.
The server window is in Steam view==>servers and shos up as game RK under Spacewar.
If it does not work it is most likely that your ISP is blocking the ports 7777 and 27015 for UDP and TCP.
I have Xfinity (Comcast) and their cable modem does not let those ports through and there is no easy way to change that. (lame!)

I can not get this to run on my home machine, but I have a machine on the public internet outside Xfinity and it works fine there and can be seen on the Steam server window.

Here is a read only public access SVN of both the source code, and a binary build.


If it still does not work with your appid then it is likely that your game on Steam is not configured with a “tool” that is a dedicated server, so the server list will not show it.

Hey thanks for helping.

I’ve read through some of your guide and have tried a few things like creating a tool which is set as a dedicated server and has the same product name as “STEAMPRODUCTNAME” which houses my server but I’m getting the same thing.

I am using a VServer to host my game and I am able to connect to it using the ip which indicates that the ports are working. The server shows up in the “View > Servers > Internet” tab if I use 480 which suggests that there might be something mis-configured with my steamworks setup for my game’s personal appid but I don’t know what it is.

I have also had a look through the “5. Common Issues and Details Checklist” part of your guide and have made a few changes but again, no change.

That SVN link doesn’t work for me. It says Error Took too much time to load or something like that. I am using Tortoise SVN.

Try getting the binary distribution of the dedicated server test app at


and see if it works on the Spacewar server app id 480.

If it doesn’t it means you have firewall issues.

The SVN link worked for me

It works I ran the server on my desktop and it showed up in the internet tab on both my desktop and my laptop

If the link works, can you upload to Google Drive and send it to me too because I can’t access it…

Here you go - Google Drive

I’m on UE 4.19.2

I encountered the problem on 4.18, but it works perfectly on 4.19 (for me). Although, I cannot contradict you because I have a friend whose dedicated server works pefectly for 4.18, so… I would just suggest you to wait for 4.20 and download it from source.

That’s what I’m planning on doing. I’ve also sent a Steamworks support ticket to see if there is anything they need to do that can help.

Hmm, can you keep me updated with this issue. I mean can you let me know what they told you. I am really curious about this.

They’ve replied

Hi, we need to enable the Matchmaking API for F2P titles, but your app appears to be paid. I recommend reading through our documentation: Steam Matchmaking & Lobbies (Steamworks Documentation)

So basically they passed on this qustion, huh, nah man wasn’t expecting help from them either…Read our documentation, they don’t have to tell me to do that cuz google is already there

Well, 4.20 is out and I’ve been met with the same issue. The advanced sessions has even been updated to support it too and everything is still a mess

I have the same problem, Dedicated Server doesnt appear on steam server list, even over network, but i can connect to it.

how to download this asset in game?