Dedicated server build crashing on start

Building the dedicated server executable is successful, but it crashes immediately after trying to start it.
I am currently investigating but haven’t found anything obvious yet. The dedicated server executables are built after the latest documentation and has no problems compiling.

I haven’t been able to get any dedicated server build to work since UE 4.11. Before this they always worked perfectly fine.

Any advice is appreciated. /Best Regards.


I’ve tested and gotten a dedicated server built and running successfully. I used a combination of the following wiki pages:

Note the changes to the Target file for 4.15.

Give this a shot in a clean project and let me know your results.

Greetings, thanks for helping out.
I get the same crashes in a clean project. Not sure whats going on here, but the crash stack is identical. I’ve compiled a sample project which gives this crash when I execute the dedicated server.

It can be downloaded here

This is also setup using the latest documentation for 4.15, it is also using the steam oss, and no async or event driven loading (since problems was reported using these).

Thanks for your assistance /Best Regards

Unfortunately, I’m not able to get that running. I get the failed to open descriptor file message. Do me a favor and set up a clean project for this and then provide me with the zip of the project instead of the packaged server. That way I can check all of your settings and ensure the server target file is set up correctly, and then attempt to build the server on my end.

I apologize, I had changed name on a folder and forgotten to refresh the project code files. Ive also removed the built files to save space and only include the project.

Fixed project download here

Thanks for providing the fixed project. I’ve run through the dedicated server setup project, and I’m not seeing the crash occur on my end.

I highly recommend using the guide I linked earlier, if you haven’t already. For 4.15, you’ll also need to remove the GetSupportedPlatforms function as well as the two that are commented out for 4.14 and later: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

I’ve tested it two times in the project you’ve provided, and the server is running as expected. As a result, we do not believe that this issue is a bug. If you find new steps that consistently reproduce the issue, feel free to leave a comment to reopen the thread and we can continue to investigate.

Have a great day

Thanks for helping out. I am a bit confused why the server won’t run on my end. There are no compile errors. The sample project uses these target files and should be correct: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Could you upload the built/packaged sample project that works on your end so I can try if it still crashes here, if so there would be some other bug or issue with windows/drivers/dependencies that prevent it from running for some reason.

/Best Regards

I went ahead and created a test project for you:

link text

So this one is all ready to go. Here’s what you’ll need to do:

  1. Generate Project Files
  2. Open the project and package it for Win64
  3. After packaging finishes, open the .sln and change the build configuration to Development Server and build the project
  4. When the build is done, go to your project folder → Binaries → Win64 and copy the AH581303Server.exe
  5. Go to the folder where you packaged your game and open Binaries->Win64 and paste AH581303Server.exe in this folder
  6. Right click on Server.exe and copy. Then right-click somewhere else and choose “Paste Shortcut”
  7. Right click on the shortcut and go to, “Properties”.
  8. At the end of the “Target” line add, -log
  9. Run the shortcut

Running through these steps, the server worked as expected without crashing.

Thanks for helping out. Your project does indeed work. I believe I’ve found the problem. Its not possible to run a development server with a shipping game build. Also async loading needs to be disabled or it may/will crash the server.
The particular issues I experienced in this post seems to be solved.

Thanks for your time helping to sort out these issues, you assistance is most appreciated! /Best Regards