Download

Dedicated Linux Server

I’ve followed along through the tutorials below and was able to build/cook a Linux dedicated server but I’m not seeing the client connect in the server logs, and I’m not sure if I’m actually connecting or not.

This is all that shows up in the log on the client side:
[2016.01.15-15.31.06:696][477]LogNet: Browse: 127.0.0.1//Game/StarterContent/Maps/Minimal_Default
[2016.01.15-15.31.06:696][477]LogInit: WinSock: Socket queue 32768 / 32768
[2016.01.15-15.31.06:702][477]LogInit: WinSock: I am xxxxxxxx (xxx.xxx.xxx.xxx:0)
[2016.01.15-15.31.06:702][477]LogNet: Game client on port 7777, rate 10000
[2016.01.15-15.31.06:702][477]LogNet: GetLocalNetworkVersion: GEngineNetVersion: 0, ProjectName: vmet3d, ProjectVersion: 1.0.0.0, InternalProtocolVersion: 9, LocalNetworkVersion: 945245530

Tutorials I followed:

Is there a quick and dirty way to display a message from the server on the client that I successfully connected?

It looks like client is connecting to 127.0.0.1 – are you running server on the same computer as client?

“WinSock” suggests that client is running on windows; subject line suggests that server is running on linux – they would have to have different IP, or if linux is inside some sort of VM inside windows, make sure you are forwarding ports (port 7777 UDP traffic) correctly.

I’ve tried it on a remote server and a local VM and I’m getting the same results. They’re both CentOS 6.7. I’m able to communicate with netcat on 7777 so I think the ports are set up correctly. However, I’m hoping to eventually tunnel 7777 through SSH, which is why I’m trying to get this working, to see if that’s possible.

I’ve gotten a little further on my remote server by using the IP address instead of the hostname… ? But it just takes me to a black screen. I haven’t created any levels/maps or anything. All I did was start a First Person C++ project, added a landscape and a Light Importance Volume, built it and followed the dedicated server directions from there.

Here’s what showed up in the server log:
[2016.01.19-18.41.32:193][962]LogNet: NotifyAcceptingConnection: Server Entry accept
[2016.01.19-18.41.32:193][962]LogNet: Open Entry 01/19/16 12:41:32 x.x.x.x
[2016.01.19-18.41.32:193][962]LogNet: Added client connection. Remote address = x.x.x.x/x
[2016.01.19-18.41.32:193][962]LogNet: NotifyAcceptingChannel Control 0 server World /Engine/Maps/Entry.Entry: Accepted
[2016.01.19-18.41.32:193][962]LogNet: Remote platform little endian=1
[2016.01.19-18.41.32:193][962]LogNet: This platform little endian=1
[2016.01.19-18.41.32:193][962]LogNet: GetLocalNetworkVersion: GEngineNetVersion: 0, ProjectName: vmet3d, ProjectVersion: 1.0.0.0, InternalProtocolVersion: 9, Lo calNetworkVersion: 945245530
[2016.01.19-18.41.32:293][965]LogNet: Login request: /Game/StarterContent/Maps/Minimal_Default userId: Invalid
[2016.01.19-18.41.32:360][967]LogNet: Client netspeed is 10000
[2016.01.19-18.41.32:426][969]LogNet: Join request: /Game/StarterContent/Maps/Minimal_Default?SplitscreenCount=1
[2016.01.19-18.41.32:474][969]LogNet: Join succeeded: 256
[2016.01.19-18.41.32:575][973]LogNet: Server connection received: ActorChannelFailure

I googled ActorChannelFailure but didn’t find anything real useful.

That error usually means that the version of blueprint of your character on the server, and on the client, are not the same.

Re-cook/package both server and client and try again…

I really do appreciate your help. I did as you suggested just before I left yesterday and managed to get rid of the ActorChannelFailure but I still get the black screen. I’m wondering now if it has something to do with some security settings on my desktop. I’ve read where people had a similar issue with a certain type of ethernet adapter.

But here’s a stupid question. I looked into this a year or so ago for something else I was playing around with and the requirements for a Linux server included a beefy GPU, but the more recent documentation doesn’t mention that and says that you can run a dedicated server headless, so am I correct in assuming that those requirement no longer exist, or maybe I was reading it wrong?

i have a stupid error setting a server too that give me a black screen and lost lots of hours checking communication, checking configuration UE4/server, etc :mad:. Finally haven’t nothing to do with windows/linux, communication or other thing, was something really simple, If you haven’t problems in windows server ins’t that but since its something that give a “black screen” i post here.

In Project Settings->Map Modes

There are setting for maps, “Game Map” and “Editor Startup” unfortunately someone at epic think its good idea hide the other option “Server map” and give some headache to us. Just press the arrow and change to your desire server starting map.

If you don’t set the server map the server start with a empty black level not the game map. :confused:

In your log seems your server its loading the “Entry” BLACK map.

a epic member head must be roll for give us headaches for hide that :>

That was it, knack. Thank you!!!

nice. hope you not lost a entire day checking things like me for that! :mad:

i still have nightmares for the lost time until realizing that hidden and necessary option :smiley: