Download

Decals buggy and not loading materials.

Hi All, I decided to post here because I’ve been having this problem since 4.6 now, Hopefully someone can shed some light on the issue.

Essentially I have a decalactor with deferred decals enabled in the .ini file, But the weird thing is how Decals behave in editor. I have made a Decal Material, And a Deffered Decal Actor. I managed to load the material into the Actor previously however after saving it now refuses to load the same material which is used on working decal actors into a new one. When I load it by either scrolling through the material list, click dragging the material onto the material input in the decal details it just remains blank. any ideas?

-Could you post a pic of your decal material? :slight_smile:
-have you already tested it with 4.8?

Sure, Here is a screenshot of the material setup. I have also tested the scene in 4.8 however had the same result. I have tried using most Decal Blend Modes, Using Deffered Decal as the Material Domain with DBuffer enabled as well as using the default Decal Material setup.

any ideas? is this issue specific to my workstation or all decals

Hmm, really strange…

-do you get the same problem when you recreate the material in a new project + test it again?
-select your decal material - drag and drop a decal actor into your level -> test again :slight_smile:

Good news, If I select the material and drag a new actor into the level it creates the decal with the material applied! Thanks :slight_smile:
Still a bug with cloning the decals, But this works for now