Deactivating 2 Box Collisions (Trigger)

Hi everybody !

I didn’t find any answer on internet so I need to ask you this :

I created two separates blueprints, each containing some actors (for one is a sofa for the other a lamp).
I’ve added to them a sphere collision for the sofa BP and a box collision to the lamp BP, those collisions box & sphere are set to “Triggers” and those triggers overlap each other.
They’re working perfectly but when I’m overlaping the two triggers at the same time and I set their collision to “No collision” (with the “set collision enabled” node) in my BP’s it affects the two triggers at the same time. No matter which event I’m calling if I call one of them it affects the two triggers.

What can I do if want to set them to no collision separately & when I want to while playing?

Thanks in advance


Hello Ruba thanks for taking some time to answer my question. I cannot post any screenshots right now I’ll do it later, sorry for that. When I say it affects both of them at the same time yeah it’s mean both of them are disabled at the same time. And yes If I’m overlaping only one of them it only deactivate the good one(the one I’m inside). What’s driving me crazy is that it’s two different blueprints modifying two different objects! :frowning:

can you post some screen shots of what you are doing?

And what do you mean by it affects both of them at the same time? You mean it disables/enables them at the same time? And does this behavior change if they aren’t overlapping?

Ok, I see. Post some screen shots when you have some time and I will take a look. It’s probably something simple and you have been staring at your code too long :slight_smile:

I posted 5 images, I hope that will help :slight_smile:

The first thing that jumps out to me as being off is that your lamp table inherits from TriggerBox. I would think it should be an actor that has box collision on it and that box collision is set to trigger.

The second thing is you’re using input touch being and input touch end rather than the overlaps to control the trigger. Based on your description that doesn’t seem like what you want to do.

I recreated my blueprints using actor BP as you said and also using box collision set to trigger.

About the second thing I want that when I touch on of the object the highlight disappear it disappear by setting the collision of the trigger to “no collision”.

So even with those new BP I still have the problem I made a litlle schema to show the error. :slight_smile:

hey :D, you could use this in your triggers. it’ll helps you that the only one can activate the triggers is the character.

hope it help in something.

yes I didn’t see the image so I change the collision directly in my Trigger menu.

Anddddd it works ! Thanks a lot the two of you !!

Awesome! :smiley: