DDS (or DirectDraw Surface) Images don't import

When I try to import a .dds image file into the UE4 editor, they never seem to import. It just throws up a "Failed to import ‘Insert File directory and name’. Failed to create asset "Insert UE4 File directory and name’ "

Now, this seems to happen with ALL DDS files that I attempt to import.

Does anyone know why this is happening? Or maybe if there is a way to fix it?


same here , i tried a bunch of different version, 8 bit, 16 bit even 32bit float. but non e are able to import.

Here you can see what image types are supported. Can you check if the .dds is 32bit texture?

edit: theese seems to be the settings you should go for when using .dds " (32bits/Channel, ARGB 32 bpp, unsigned) See Cubemap Tools for more information."

Moore info on .dds can be found here:

I seem to be having the same issue. I check Task Manager whenever I attempt to import, and UE4 instantly changes to ‘Not Responding’ forcing me to end it manually.

This does solve the problem of not importing. BUT while in the process of saving it as that file type, it converts Texture Maps (RGB and so on) into Normal Maps.

Why does UE4 only support this DDS file format?

Hi Freakazoid,

Please take a look at the forum thread below for more info on this.

Hi here !,

As MaxDiehard said earlier, I have the same problem. I try to import my dds file made with the NVIDIA tools for Photoshop and saving as ARGB 32 bpp unsigned, but it doesn’t work. I tried different versions 8bit, 16 bit or 32bit, but Unreal always freezes … And I have to end it manually.
The file size is 6146*1024 for 25 Mo, so technically it’s not to heavy for Unreal. I’m working on UE 4 4.4.3.

Thanks for your help !

Hi Emy-Lili,

Make sure that your image is a power of 2.

Sorry, both of the links are changed.

I used imagemagick to batch convert from dds to tga with the command, magick mogrify -path "\outputFolder" -format tga \inputFolder\*.dds. It worked for me. In case you want to convert dds to dds magick mogrify -path "\outputDir" -format dds \inputDir\*.tga, but in this case you might need to pay attention to the formating, i.e., A8R8G8B8 (32 bpp, unsigned, no Mipmaps). I believe that is also possible with imagemagick.