Dbgeng.dll fails and crashes unreal with 100% repros

Hey all,

I’ve been using Unreal stably through production for the past several months. This sunday, however, I installed all of my drivers and tools for the Oculus (sdk 4.3). Oculus demos and tools run fine, but when I open Unreal, in either your build or my own packaged build, I crash 100% through a wide variety of actions, the easiest being to simply mouse over the generic browser.

This is what I’m prompted with:

20217-untitled-2.jpg

As I understand it, this file is actually telling me that the crash report is failing because of dbgeng.dll, not indicating in anyway what is actually causing my crash. Either way, I can’t move forward.

  • I’ve tried every other link I could find of CrashReportClient.exe or dbgeng.dll here in the answerhub, to no avail. This was the most useful, but I don’t actually have dbgeng.dll in these directories. [CrashReportClient.exe - Entry Point Not Found - Platform & Builds - Unreal Engine Forums][2]
  • Uninstalling all of the oculus drivers and disconnecting the oculus does make the engine more stable, but only to the extent that I could work for about 5 minutes without crashing, as long as I don’t try to bake, build, or run in an external window. Re-installing the SDK and drivers brings the immediate crash back.
  • I’ve tried every other recommended solution I could find online - registry cleaners, removing and re-installing all related software, including Unreal, updating my OS, and am stopping just short of reformatting now as I post this. (I’ll probably reformat and try again once I press post.

I’m posting this question out to Oculus as well, but I’d love any further guidance you can provide as to a way to fix this, or a way to prevent this once I’m on the other side of my reformat and try to install unreal and the oculus again.

Thanks!
Keith

Ps. I’m on Windows 8.1, on an SSD with a GeForce GTX 680.

1 Like

Hey keithguerrette-

There are a few test I’d like you to run to narrow down the possible causes of the crash. After uninstalling the SDK are you able to run the engine? Rather than using the 4.3 SDK can you install and run the 4.2 SDK? Let me know if either of these have any effect for you as well as any other information you can think of.

Cheers

Hi ,

Thanks so much for the response.

I’ve tried uninstalling all of the oculus drivers/SDK and re-running Unreal. It does seem to make the engine slightly more stable, but only in terms of minutes before I crash. I am still 100% unable to bake/build an executable.

I still need to test again with the 4.2 sdk, but when I did this last week it made no difference. I’m going to have to wait until tomorrow night to try this and verify my answer for you, so I’ll post the follow up answer tomorrow evening.

Thanks again!

I’ve had to resolve this faster due to an outside deadline, so I went ahead and reformatted my machine and re-installed. So far, it seems that everything is working correctly, which ultimately means it was something wrong with my local machine.

I apologize for not being able to see this issue through, but definitely appreciate the responses. We can go ahead and call this resolved for now.

Thanks!
Keith

Hey Keithguerrette-

Thank you for letting us know. We will continue to investigate what may have caused this issue, however I am going to mark this as resolved for tracking purposes.

Cheers

10 years later :slight_smile: I get the same error with dbgeng.dll, this time for the procedure entry point StackWalk2.
I need to press the Ok button for 5 times in order to close it, then the project appears and the error appears, once again 5 clicks and the error is gone. The projects opens normally right after. I can work but if I start previewing in editor the error appears, and yess, 5 OK clicks and everything is back on track.
I got this right after Oculus Software update and when uninstalled the Oculus Software no error appears.
Interesting is that only UE 5.0.3 is affected. Other versions of Unreal Engine are working even if the Oculus Software is installed.
Did you guys found a fix for this?
Thanks.

1 Like

I am seeing this as well, UE 4.27 works fine with the older Oculus installation but as soon as I am forced to update to 63.0.0.216.361 I get the Stackwalk2 error on launch.

1 Like

This issue is caused by an outdated dbghelp.dll in Unreal Engine versions older than UE5.0, a workaround is to update this file manually to solve problems related to debugging and error handling. Here’s how to do it:

  1. Locate the dbghelp.dll file in the latest version of Unreal Engine (UE5.1 or newer).
    Copy this updated dbghelp.dll file.
  2. Replace the old dbghelp.dll file in the engine directory of your older Unreal Engine version with the copied file.
    3.Ensure you perform this operation in the engine’s installation directory, not in your project folder, and this will solve the pop up message error for both engine and packaged game.
1 Like

Try update dbghelp.dll manually from latest engine version

This saved my mental sanity and my mouse button since I’ve ben clicking the dbgeng.dll error “ten trillion times” for the past two weeks.
Thank you!

2 Likes

I’m glad it wasn’t just me that suddenly got it this week! Could anyone provide the dbghelp.dll file from 5.1+ since I want to avoid downloading an entire engine just for a file haha

Haha I feel you Adrian, I also got into quite a rage fighting the error messages lately.

For anyone looking for the file, here it is:
https://file.io/ABbbXuVpiU5A

The file location in your Engine is Binaries\ThirdParty\DbgHelp\

1 Like

Thank you Cosmo!

Hi, just a little heads up for me updating this fixed it :

https://developer.microsoft.com/en-us/windows/downloads/windows-sdk/

Its not an Unreal thing, its seems to be unreal trying to use a WIndows DLL and it needs to be updated.

Hello everyone, I ended up facing the same problem and decided to describe some steps until I found the solution.

I’m part of a team that develops a project using 4.23. This error has never occurred before.
There was a need recently to start another VR project in parallel. For this project, we are using 5.3 with Meta Quest 2. I installed the Oculus program normally, configured Quest 2 and ran it normally on 5.3.
After that, I ran the project again in 4.23 and it started showing this error:

001

I need to click OK a few times and the project opens and runs normally after the error.

When searching online, I saw something related to Oculus. I uninstalled the program for it and restarted the PC.
The error described above no longer occurred.

As I need VR for another project, I decided to live with the error.

After a few days, I decided to research this error again and ended up finding this topic.

After reading @neekstudio message, I decided to try updating Visual Studio (I have 2017 due to the 4.23 project and 2022 due to the 5.3 project), but without success.

It was then that I read @Cosmo.Romeo1 message and tried to make this update using files from another version and got the following results:

1- I took the dbghelp.dll and dbghelp.tps files from 4.25 (located in the C:\Program Files\Epic Games\UE_4.25\Engine\Binaries\ThirdParty\DbgHelp folder on my PC) and placed them in the same folder as 4.23.

The same error described at the beginning of this post appeared. After clicking OK a few times, the project opened and ran normally.

2- I took the dbghelp.dll and dbghelp.tps files from 4.27 (located in the C:\Program Files\Epic Games\UE_4.27\Engine\Binaries\ThirdParty\DbgHelp folder on my PC) and placed them in the same folder as 4.23.

The error changed and the following message appeared.

002

After clicking OK a few times, the project opened and ran normally.

3- I took the dbghelp.dll and dbghelp.tps files from 5.2 (located in the C:\Program Files\Epic Games\UE_4.27\Engine\Binaries\ThirdParty\DbgHelp folder on my PC) and placed them in the same folder as 4.23.

The same error described in item 2 appeared. After clicking OK a few times, the project opened and ran normally.

4- I took the dbghelp.dll and dbghelp.tps files from 5.3 (located in the C:\Program Files\Epic Games\UE_4.27\Engine\Binaries\ThirdParty\DbgHelp folder on my PC) and placed it in the same folder as 4.23.

The project opened normally without showing errors.

If I compare the dbghelp.dll file from 4.23 with the same file from 5.3, there is a difference of approximately 848 KB more in 5.3.

Apparently the problem was solved with this action.

If I return or find another problem, I will post here again.

NOTE: what I find strange is that a friend of mine who works on the same projects with me, basically with the same equipment, didn’t have this problem.

2 Likes

Thank you guys, this fixed it for me:
copied this file C:\Windows\System32\dbghelp.dll
pasted (and replacedted) in here “C:~~~\Engine\Binaries\ThirdParty\DbgHelp\dbghelp.dll”

9 Likes

This fixed it for me, thanks.

*Edited: Removed content I found out was unrelated to this issue.

Your project has a plugin called TimeMachine that’s failing some assertion after looking up marketplace products, doesn’t look like it has anything to do with this issue.

1 Like

Thank you, I just fixed it and found this out. I was so flustered about the first issue with the dbghelper.dll that I guess I just forgot how to read for a minute there. This first problem I had was about this topic, and I had just said the above reply helped fix that; then I went on about something else not related to the topic that I thought was before I figured that out. Thanks again, cheers.

this fixed it for me as well. thanks!
using 5.2 with meta xr plugin v57