Download

Day Night Cycle

Hi all!

I’m currently trying to implement a day/night cycle, but I’m struggling to get the basic lighting down.

This is what it looks like during the day, which

However, when I rotate the directional light/sun to set it to night, I update the skybox and get this:

This isn’t very night timey. As far as my limited knowledge is aware, the cause for this is the of the ‘Environment Colour’ setting being too bright. However, if I don’t set this, the shadows during the day are too dark (literally pitch black).

My question is, how can I have brighter shadows during the day, but retain a darker environment at night? I can rebuild the lighting. Am I correct in thinking that there is no way to modify the Environment Colour and have it update in real time?

Thanks for reading!

Theres no need for Light rebuilding in a day night cycle because Lightmass is static. What you want to do is add a PostProcessVolume with Unbound (search for it in details tab) set to true and add a AmbientCubemap. Then in Blueprint you can adjust the Ambient Cubemap intensity when the sun goes down and increase it when the sun comes up. :slight_smile:

I made a Day Night Cycle when i was beta testing Unreal Engine 4.

You can also use the WIP (BETA) Dynamic GI. https://forums.unrealengine.com/showthread.php?530-How-to-enable-Light-Propagation-Volumes-GI-WIP-AND-BETA&highlight=camera

Here is the WIKI page for it: https://wiki.unrealengine.com/Light_Propagation_Volumes_GI

I wouldn’t rely on it just yet. You can make your day & night cycle as Ryan suggested, and then switch your light to LPV WHEN it is polished.

After having this problem for a while and trying all the different solutions posted in this post as well as in this one: Night Brightness in a Day/Night Ssytem - Content Creation - Unreal Engine Forums , I’ve found that the problem lies only in the auto-exposure setting of your camera - and possibly in your global post process volume. It might seem that auto-exposure (eye adaptation) is disabled because it’s unchecked but it’s not. To totally disable it you have to check both min brightness and max brightness as mentioned here https://answers.unrealengine.com/questions/24730/how-to-completely-disable-eye-adaptation-in-a-scen-1.html and set both of them to an equal value (example =1). I did this for both my camera (myCharacter->components-> camera) and my post process volume but I think that just one of them will be enough. This will fix the problem you are having. After that you will probably have to create ambient lighting (or another kind of light source) but that’s a different thing.

I just posted here after finding the solution myself, just in case someone else like me is having a hard time with this…