Download

dawl's stuff

Hey all !

I’m Like koola (#mygod ^^ ) I start this thread to present you what i make on ue4. Unlike koola I will need your help to improve my scenes.
ps : I’m a 15 french who passionate by 3d, I’m not a professional at all. And sorry for my bad english too ( http://prntscr.com/69cdm5 )

So I’m actually working on archviz scene. I modeled all meshes in Cinema 4d, i exported my meshes with just 1 box UV mapping in .fbx.
Then I imported it in ue4 with this parameter :
I increased “Min Lightmap Resolution” and “Lightmap resolution” to 1024 and “Overridden Light Map Res” to 128.
For the lighting i’m inspired koola’s lighting : one plane and a spotlight for each windows.
And i get that :

I can notice some problem with shadow : http://prntscr.com/69d71u
I build lighting with medium setting because my pc is powerless to build lighting with high setting or production. So if a gentle person can build lighting my project for me i will be thanksfull ( add me on skype : dawlstudio ).

Setting “Min Lightmap Resolution” is for creating a second UV set inside of Unreal and only determines how much spacing there will be between the generated UV shells.
“Lightmap Resolution” is the actual resolution that the lightmap will be created at.
By checking “Override Lightmap Resolution”, you are telling Unreal to ignore the 1024 lightmap and instead build a very small 128 map.
By making a small lightmap and putting it onto UV shells that are spaced too tightly together, you are getting a large amount of shadow bleeding and errors.

You just need patience to build at Production quality. Leave it on overnight or something, because no one is going to build it for you :slight_smile:

Thanks for you answer. I will unchecking “Override Lightmap Resolution” :slight_smile:

Hi Dawl,

Depending on how many separate walls share the same mesh ( ideally each wall is a separate mesh) 128 to 512 lightmap resolution should be more than enough when you don’t have tiny shadow details like a tree’s shadow.

There is a way to fasten the building light process by changing the lightmass.ini file ( use all cores of the processor) - look it up.

Make sure the lightmap’s UVs are set up correctly.

When you come back for more feedback take screenshots this way : Hit play (alt+p) >F11 for fullscreen > open console “`” > type in HighResScreenshot 1/2/3 (where 1 is the same res as you fullscreen, 2 is double 3 is triple etc) then convert to .jpg/.png and upload here on the forums.

Hey rob, thanks for this informations :). But i don’t understand should i check “Override Lightmap Resolution” if i increase “Lightmap Resolution” to 1024 ?

Override lightmap res is just a way of changing the lightmap res from the actor details instead of doing it inside the mesh editor.

For beginners my advice is to do it inside the mesh editor, make sure the lightmap coordinate index is set right and also check the UVs of the lightmap while 2nd uv channel is selected. ( what you are looking for is that UV should be separated nicely and positioned vertically/horizontaly )

Sometimes the automatic uv layout for lightmaps screws up and doesn’t do it. If that is the case then you have to go back to the 3d soft and create there yourself the 2nd channel and reimport.

Oh ok i understand. At beginning i created in my 3d software, UV1 with box mapping and UV2 with flatten mapping for lightmap but when i imported it in ue4 and build the scene i have error messages which said my UVs are overlapping. So like my meshes are pretty simple i generate lightmap UV in ue4.

Hey, i just had some details in my scene, i change my baselightmass.ini to the koola one.
HighresScreenshot00011.png
HighresScreenshot00012.png
HighresScreenshot00008.png
HighresScreenshot00009.png
HighresScreenshot00010.png
HighresScreenshot00007.png
HighresScreenshot00013.png
I still have problem with shadows…

That looks a like a lightmap UV problem. Post a screenshot of the uv layout inside the mesh editor (of a problematic mesh).

Also post a screenshot with lightmass settings. Settings> world settings > lightmass.

Here yhe lightmass settings
ff930f07589046948f14c17a3595417da8fdc5c6.png
But for uv layout i have so many object and no message error… : 7a780068196533ae790752f52412897b0a4d0eed.png

Give it a try with lightmass settings to :

Static level scale : 0.8
Indirect light bounces : 10
Indirect light quality : 10

I can’t see any UV layout. Just pick one mesh that you see shadow errors and open the editor , select the 2nd uv chnnael and click show UVs.

Hey, I just built the scene with your setting and there are no big change but i think i a little better and more luminous ! Here a uv of mesh which i see shodows errors :
7294035f4135cec9b88b970843cef43bdfcc3cc2.jpeg

https://www.youtube.com/watch?v=SD4q5Ewn_-o check this !

Very nice, I love the architecture!

Thanks man ! :slight_smile: