DataTable localization doesn't work?!

Was the Data Table set-up directly in the editor, or was it imported from a CSV or JSON file?

Hi, I’m using the localization dashboard to translate Text. This works fine for Widgets, and Structs, but my DataTables won’t get translated ingame.

The Text inside is gathered by the localisation-DB, i translated it and compiled, but the text just wont show up ingame, while Widget and Struct Text is translated well. The DataTable is just some rows of single Text.

What am i doing wrong? I’m useing -culture=blabla and Standalone for preview.

Thanks so much for help guys :slight_smile:

It was set-up in the editor. I typed all Text in manually.

The DataTable was created, the Struct was added, i typed 100 rows of Text manually. After that i exported the Data for Backup, but i don’t remember reimporting it.

Could you open one of your .archive files (they’ll be found under Content/Localization) and verify that the translation data for a random key from the data table is present?

Yes,“Key”: “CDB728AA49CE2FF92092CE9A56EBB88E” has a valid Source {} and Translation {} The Key is valid in the DataTable for the same Text. It is marked as translated in the localization dashboard, under “translated” category.

However the translation doesn’t show up ingame after compiling, but the translation directly in the Widget-Texts and other assets show up right beside it. If I run the game as standalone my widget-menu is translated, but the text i add from the data-table to a textbox is not translated. I’ll take a screenshot in a moment.

I deleted my Translation just to show this to you without any confusion:

I’ve set up translations for the UI (back buttons) and this one line in the data-table, that will dynamically be added in the widget. (Get data Table row → break → text → …)

The KEY fits the DataTable Text Key

In StandaloneGame I see the working translation, and the untranslated DataTable source-Text side by side. How is this possible?

Hey, after manually resetting all 100 Text Keys in the data-table, the translation works. I don’t understand this Problem, but I’ll run with it ^^
And it is a lot of work, setting all those keys up…
I wonder what my mistake might have been…

Sigh, just ran into this myself… everything works but the DataTable (which are the heaviest and already tied into my logic) ones…

Going to try this out, just ran into this… When I was first testing it, it was working, the widget was Localized, but that was with regular Text variables. I was satisfied and started putting it all into DataTables… then I just imported our first few localized languages…and it doesn’t translate into the correct language… rofl…

I spent quite a bit of time setting up the proper workflow… but of course… something had to go wrong :slight_smile: Dev Life

When you moved them, did they keep the same namespace and key as your old localizations (or did you re-localize after)?

Which version of UE4?

Yeah, kept the same. All I did was overwrite the Game.po in each language as that’s the only way I’ve found to actually import the languages correctly into UE4.

So, export all languages, then import all languages after overwrite each language’s Game.po.

I was able to actually get this working by compiling a second time after reopening my editor. Basically, once I import all languages, I compile all languages. For some reason it wasn’t working for the DT entries, which led me here, but this solution didn’t work for me.

Luckily (or not so) my editor crashed after trying to open up (edit language) one of the languages to check if there was something missing. Can’t remember the exact timing, I think it may have been when I was trying to double click in one of the text lines, anyway it crashed. I recompiled and it worked.

Hmm, did you compile with the editor open and expect that to refresh live?

We don’t watch LocRes files for changes, but since it’s game data, going into and out of PIE (with a game preview language set) should have refreshed it.

Why wouldn’t I be able to compile the game text with the editor open? I have to click the button inside the Localization Dashboard. How else could I do it with the editor closed?

Unless you mean, if I expected it to work while I was in PIE, then no. Because I don’t usually have PIE open when I compile anything in game.

Yeah, I meant the latter.

Very strange then, but it sounds like it’s working now.

Hello if someone’s seeing this. When you update your PO files, just compile and build everything, close and re-open the editor and it will refresh the changes.

1 Like