Datasmith Export Problem

Hi everyone,

I’ve got a problem with exporting out of 3dsmax with the datasmith exporter and importing into unreal studio. The meshes export without an problem the first time I open my 3dsmax scene and exporting out of it. But if I export a second time (even with no changes to the scene and meshes) all the meshes are distorted when importing to unreal. The error occurs with overwriting the udatasmith file and with creating a new one. When I save the 3dsmax file and reopen and export again, everything exports right again. But still, just the first time.

Does anyone know how to fix this error?

Best Greetings!

Hi Link-3D ,

I’m unable to reproduce your problem but may i suggest that you try using the re-import instead of importing twice?
To do so , Find your Datasmith scene, right click → select re-import
Let me know if that fixes the problem ?


thank you for the reply. Reimport was the first thing I tried, but I get the same result. It must have to do something with the max export into a udatasmith file. If I export the same object in fbx it works all the time. Just with the udatasmith extension only the first time after opening max. I’m using Max 2019.
Is there a way to share with you an example max file which produces the error? Maybe I used a modifier or similar which is not compatible with datasmith, even if the object is at the moment just a collapsed editpoly.

I don’t know if it helps. But the distorted mesh issue is likely because of the invalid transformation of the meshes. Try to force Reset X-Form on the meshes and try to reimport it separately Just to check. If look at the scale setting or rotation you can see that there will be some negative values in there.
.The issue with these meshes is that u can’t correct it in even Ue4 itself , the more u try the more weird the transformations get. So try to reset them in Max only. Hope this Helps!!

The best would be to log a support ticket with the 3ds max archived so we can inspect it and a video captured from your screen showing what you have done (OBS is a great video capture tool).

This is korean unreal user.

Here is one possible way to fix your issue. Not sure but worth it. Might be work.

  1. Open empty a new 3dsmax file

  2. Merge the issue max file.

  3. Reset xform and convert to poly.

Try again export via unreal datasmith plug-in.

Good luck!

(after 4.24 i also try to be sure match to unreal and data smith version to 4.23 i use 4.23]] but this is not important i think…)